SDDM blanck screen

Linpassion

New Member
Hi! I'm try to install SDDM on my Slack 14.2 x86-60. I use the package downloaded form

https://slackware.pkgs.org/14.2/alienbob-x86_64/sddm-20140508git-x86_64-1alien.txz.html

then I check the dependicies

bash-4.3#ldd /usr/bin/sddm | grep 'not found'
whith no output therefore I change rc.4 file

if [ -x /usr/bin/sddm ]; then
exec /usr/bin/sddm
fi
and reboot to obtain a blanck screen. So by init 3 I do a greeter test

bash-4.3#sddm-greeter --test-mode --theme maui
sddm-greeter: error while loading shared libraries: libxcb-xkb.so.0: cannot open shared object file: No such file or directory
I chek if library exist
bash-4.3# whereis libxcb-xkb.so.0
libxcb-xkb.so: /usr/lib64/libxcb-xkb.so.1 /usr/lib64/libxcb-xkb.so
Suddenly I re check the ldd outpu, then I see this

bash-4.3$ ldd /usr/bin/sddm
linux-vdso.so.1 (0x00007ffca3feb000)
So I think this is a problem, than grep "not found" not see.

Thanks!
 
Last edited:


captain-sensible

Active Member
well qt5 is a dependency of SDDM so you need to get it one way or other. At least the version of qt5 at slackbuilds should match that required of SDDM slackbuild version.

There are advantages of going slackbuild route rather than straight to a binary package


Im on current 64 bit and have
qt5-5.9.7-x86_64-1ponce
qt5-webkit-5.9.0-x86_64-1ponce because they match the requirements of of a pkg i have.
 

captain-sensible

Active Member
from a 64 bit current context these are the dependencies with Sbo

Aliens latest package for sddm current appears to be sddm-20140508git-x86_64-1alien.txz

I think with Aliens package he has it built in with deps
 

Attachments

Last edited:

Linpassion

New Member
My Salckware 14.2 is not current. I decided to not continue for sddm way, than choose slim.
 
Last edited:



Members online

No members online now.

Latest posts


Top