• We did not send an email asking for donations - please read this post.

Sendmail not signing mails with opendkim

helpmeplease

New Member
Joined
Jul 6, 2022
Messages
2
Reaction score
0
Credits
20
Hi,

I have an AlmaLinux 8.6 server with sendmail running. Today I installed opendkim, but the mails are not signed by sendmail. I have the following configuration (only included that I think is interesting here ...).

Bash:
# opendkim.conf
Socket  inet:[email protected]
KeyTable /etc/opendkim/KeyTable
SigningTable refile:/etc/opendkim/SigningTable
InternalHosts refile:/etc/opendkim/TrustedHosts
OversignHeaders From

# keys for the domain in the directory
/etc/opendkim/keys/domainname/selector-name.private / .txt

# KeyTable
selectorname._domainkey.domainname domainname:selector-name:/etc/opendkim/keys/domainname/selector-name.private

# SigningTable
*@domainname selector-name._domainkey.domainame

# sendmail.mc
INPUT_MAIL_FILTER(`opendkim', `S=inet:[email protected]')dnl

What is missing, there are no error messages. And I find entries in the maillog, for domains that are not listed in the SigningTable like this. So I think the milter should be working?

Code:
Jul  6 16:26:49 jupiter opendkim[1005578]: 266EQmLK1010249: no signing table match for '[email protected]'
Jul  6 16:26:49 jupiter opendkim[1005578]: 266EQmLK1010249: no signature data
Jul  6 16:26:49 jupiter sendmail[1010249]: 266EQmLK1010249: Milter insert (1): header: DKIM-Filter:  OpenDKIM Filter v2.11.0 host 266EQmLK1010249
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
5,026
Reaction score
3,696
Credits
36,641
Try adding "Mode sv" to /etc/opendkim.con, it's under this section.
## Selects operating modes. Valid modes are s (sign) and v (verify). Default is v.
## Must be changed to s (sign only) or sv (sign and verify) in order to sign outgoing
## messages.
Mode sv
Why did you choose to use Sendmail instead of Postfix which is the default for Rhel clones?
 
OP
H

helpmeplease

New Member
Joined
Jul 6, 2022
Messages
2
Reaction score
0
Credits
20
Try adding "Mode sv" to /etc/opendkim.con, it's under this section.
Exactly the solution, thanks a lot, had unfortunately always overlooked this option.

Why did you choose to use Sendmail instead of Postfix which is the default for Rhel clones?
Started for a few years with centos 7 and sendmail, no special reason why, and never changed it ...
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
5,026
Reaction score
3,696
Credits
36,641
I worked with Sendmail for a short while on a system I was managing and found it hard to understand. I migrated that system to Postfix when migrating from Rhel6 to Rhel7. The Postfix configuration is a lot easier to understand than Sendmail, might be worth looking into.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online

No members online now.

Latest posts

Top