SFTP not working for 1 domain only on server


New Member
Oct 25, 2019
Reaction score

I'm new here so I hope I'm not overstepping by simply coming onboard with the community with an issue - hopefully I can contribute too! Very strange issue. I have a Cloud Server with Ionos running Plesk Onyx and all of a sudden one domain I can no longer connect via SFTP or FTP via FileZilla.

Other domains are no problem. Only this one. Any ideas on where to look first would be great.

Thanks in advance,

Hey webraven - welcome to the site!

Is this site/domain working well otherwise? The domain hasn't run out has it? Is it pointing to the right IP in dns? Lastly, is it possible that plesk has disabled the account with some auto-billing feature?
There are multiple possibilities. What does "can no longer connect" mean?
  1. Are you getting time out errors? Authentication Denied errors?
  2. Does the server/domain respond to ping?
  3. Can you SSH to it?
  4. Do you have any physical access to verify that the SSH service is running?
  5. Is it possible that a firewall is blocking SSH traffic?
  6. Is it possible that the account you're using is locked due to too many bad password attempts?
Hello & thank you! This is incredible - how refreshing to get some competent feedback (something host support should be doing!)

The site is working fine as far as I can tell other than the SFTP connection issues. And, the DNS zone appears to be fine, although the zone is managed at the registrar. All I did was point the A record to the IP address: All good in Plesk as far as account being active.

Apologies, the domain is: DrJoelDavid.com

To answer TechnoJunky:
1. In FileZilla, I'm getting a "Error: Could not connect to server" error:


2. Ping seems to work. I get the same result in my Mac terminal window when I ping another domain that is known to be working: AbsoluteZero.space

3. I am able to SSH into server just fine.
4. I can log into the Ionos Cloud Server dashboard. But, like #3 above, SSH seems to be working fine.
5. Firewall I have checked several times. Port 22 is open and other domains are working.
6. Account being locked due to pass attempts ... hmm. Most attempts if not all have been with correct password, and I've changed it a couple of times to ensure.

I am at a loss as to what I should do next. I've addressed everything above and I'm just stumped. I keep thinking, "What Else Can it Be?". I've tried regular FTP too.

One more thing, IMPORTANT, sorry ... a support ticket came back saying I don't know how to connect to SFTP and it can be tricky and they stated they connected no problem. I totally don't know how this could be true!

If there is anything I can do to assist you guys, just say the word, I'm really needing to be able to connect and I'm equally invested in wanting to learn more about this challenge too!

Thank you!
I'm probably not going to be much help, but I'll throw out a couple of ideas....

FileZilla's Site Manager will let you "duplicate" one of your accounts. So you might make a copy of a working account, and then modify it to match the broken one. This could help if you are just missing some small detail somewhere.

I don't use SFTP, so I'd have to question Port 22 (SSH) versus Port 21 (FTP)... especially when you tried to use regular FTP instead. I have 6 domains that I ftp into, and none are configured with any specified port number in FileZilla... they are blank. My Protocol is simply regular FTP (not SFTP) and the "Encryption" says "Use explicit FTP over TLS if available."

Good luck!
  • Like
Reactions: Rob
OMG - Amazing! Duplicating the FileZilla site entry worked! THANK YOU! I did go ahead and take another look at the old entry and it all looks the same. I'm thinking maybe it's corrupt or something. Who knows but way to think outside the box atanere!