snow/static display? linux mint 21.3 on lenovo ideapad slim 1-14ast-05


New Member
Mar 2, 2024
Reaction score

I am new to the forum. I have been using linux for over 10yrs now, mostly to keep my weak/decrepit computers functional, since I basically do not need a lot of computing power. And since I am generally not a friend of Windows in any incarnation

I am usually able to search for solutions to the problem I have and do what is suggested to fix that problem. This time, however, I am at an end

I have a Lenovo ideapad slim 1-14ast-05 that I installed Linux Mint 21.3 on. I can run Linux as live system in compatiblity mode, but in normal mode, I just get snow and static after it finishes booting. There is also the notice that the drivers for "Stoney" are missing. When I look at the hardware list, it shows

display Stoney [Radeon R2/R3/R

so, I found what I believe are the correct drivers here

Now, the questions are:

will those be the right drivers?

can I add them to the installed system from the live system? how?

or would it just be better to install a different distribution?

or can I just reinstall the system and add the drivers during the new installation?

Thanks for any help
Last edited:

G'day jademigo, Welcome to

This is a bit beyond my paygrade, however, I also run LM21.3, but without a video card. my system relies on inbuilt graphics on the motherboard.
If you click on menu, and the type in Driver Manager on that, and it will start a scan.

No doubt it will tell that no driver is you have already discovered.

Just as an experiment, can you opt to use whatever driver etc that may be already on the motherboard?? .....this would be ignoring the presence of your graphics card.

Let us know if that is feasible.
After I have had a look around I found the same page as you the chances are it will be correct

So, if this were me, I would try the install on the Live session first.
(be aware that after you actually INSTALL 21.3, you will need to install the drivers again)

You can follow the isnstructions at that link.....or after downloading the drivers simply doube click on it and then a single click on Install Package.

If, for whatever reason, you need to can do so via terminal

sudo apt purge package/app name

which would become...

sudo apt purge amdgpu-install_6.0.60002-1_all.deb

Copy and paste that in for accuracy

I believe those drivers will work for you
Thank you for the reply. I will give that a try, when I find some free time again

Also, i believe my device's graphic is also integrated - not a separate device. I had read somewhere (could not find the link again) that these problems were reported with the introduction of kernel 5.15. The suggestion was to try the edge version, since it now has 6.2. Where I had been unable to run even the live session of the "regular" 21.3, the edge version functioned properly, it seemed

Thx again
If you are running Mint, then from a terminal run inxi -G and then copy /paste the result back
Hello Brickwizard

Thank you for your reply. Here is the "full report" (since I'm having other issues now, too. Minor and live-with-able problems...but still irritating...)

Host: dg-Lenovo-IdeaPad-Slim-1-14AST-05 Kernel: 6.5.0-21-generic x86_64
bits: 64 Desktop: Cinnamon 6.0.4 Distro: Linux Mint 21.3 Virginia
Type: Laptop System: LENOVO product: 81VS v: Lenovo IdeaPad Slim 1-14AST-05
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0R32802 WIN
serial: <superuser required> UEFI: LENOVO v: CWCN19WW date: 05/18/2020
ID-1: BAT0 charge: 28.3 Wh (89.3%) condition: 31.7/35.0 Wh (90.5%)
Info: dual core model: AMD A6-9220e RADEON R4 5 COMPUTE CORES 2C+3G
bits: 64 type: MCP cache: L2: 2 MiB
Speed (MHz): avg: 1194 min/max: 1200/1600 cores: 1: 1189 2: 1200
Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] driver: amdgpu v: kernel
Device-2: Acer EasyCamera type: USB driver: uvcvideo
Display: x11 server: X.Org v: driver: X: loaded: amdgpu,ati
unloaded: fbdev,modesetting,vesa gpu: amdgpu resolution: 1366x768~60Hz
OpenGL: renderer: STONEY (stoney LLVM 15.0.7 DRM 3.54 6.5.0-21-generic)
v: 4.5 Mesa 23.2.1-1ubuntu3.1~22.04.2
Device-1: AMD driver: snd_hda_intel
Device-2: AMD Family 15h Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k6.5.0-21-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
driver: ath10k_pci
IF: wlp2s0 state: up mac: 94:08:53:9d:1e:2f
Device-1: Qualcomm Atheros type: USB driver: btusb
Report: hciconfig ID: hci0 state: up address: 94:08:53:9D:1E:30 bt-v: 2.1
Local Storage: total: 58.24 GiB used: 15.73 GiB (27.0%)
ID-1: /dev/mmcblk0 model: MMC64G size: 58.24 GiB
ID-1: / size: 56.53 GiB used: 15.72 GiB (27.8%) fs: ext4
dev: /dev/mmcblk0p3
ID-2: /boot/efi size: 512 MiB used: 6.1 MiB (1.2%) fs: vfat
dev: /dev/mmcblk0p2
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile
System Temperatures: cpu: 35.0 C mobo: 27.0 C gpu: amdgpu temp: 27.0 C
Fan Speeds (RPM): N/A
Processes: 216 Uptime: 23m Memory: 3.64 GiB used: 1.38 GiB (37.8%)
Shell: Bash inxi: 3.3.13

I went ahead and installed the linux mint 32.1 Cinnamon (Edge ISO)

and it works, so YAY

but now I'm trapped in boot menu hell

When I boot, I get this


i've kept deleting and installing, trying to get rid of all the gunk. i went into gparted from a live system and deleted all partitions, but i still keep getting different boot menus

this device came with win10 preinstalled. my first attempts at a clean linux installation would result in a boot menu with the option to boot win10 which i had deleted from the hard drive and wiped from the boot menu with efibootmgr but then it still prompts for windows or windows recovery system or i get multiple ubuntu boot prompts (as i kept installing linux mint), as depicted

just click on one, i hear you think, but, i can't. my system won't move beyond this screen. i can click whatever it offers or ESC and it is undead nonetheless

i can end run around it by entering BIOS and just exiting. i dont have to do anything else. it will then boot correctly


i have tried both uefi and legacy boot modes. it does not change my result

i can keep running around the problem, because that works, but it would be much sexier if it REALLY worked, like it's supposed to, but I don't know how

here's hoping it doesn't melt my mind

thx again
OK do
1] make sure you have disabled Windows quick-start and secure boot [if you have them] in the BIOS,
2] [] This is the standard boot screen, do not delete it or the system won't boot
the boot screen is usually visible for 5 to 10 seconds depending on distribution [you can reduce this using the terminal].

Now we have more information I can see that the machine is 7 yrs old so it will be UEFI
the only thing on the machine which may cause concern is the 64gb MMc flash drive [they are not known for their longevity [I would be inclined to test it]
Hello Brickwizard

I couldn't find Windows quick start in BIOS, but secure boot was active, so I disabled it. I didn't notice any change at first, then I noticed, that, when I just RESTART, I land back in boot-menu-hell with 2x ubuntu and it won't go away and i can't click on anything. Then, I noticed, that, when I SHUT DOWN and power up again, it boots normally without a boot menu, so YAY sexy booting is back

Interesting for me, too, is that I saw somebody in a youtube video keep F12 pressed and hit the power button with this device, so I tried that, and the boot menu appeared with 2x ubuntu prompts again but, this time, with a third prompt: eMMC Card: Ramaxel 64GB. And that prompt actually works and powers up the system. I tried moving that to the beginning of the boot order, but it still will not RESTART normally

Anyway, thanks to Brickwizard and Condobloke for helping me out. I'm happy with the result. This device is a plaything, really, which I bought to replace a tablet that broke. At youtube, it was called a "tablet with a keyboard", which I think is appropriate. May it last for 10 more years!

Thanks again for the help

Members online

Latest posts