So sound from speakers | Realtek ALC287

saidtaylann

New Member
Credits
18
Hey,
I have a Lenovo Legion 7i and sound card codec package doesnt support. So i must use Windows :(
What can i do about the matter?
 


Condobloke

Well-Known Member
Credits
15,882
So, it may be worth perusing the page which Nelson linked to and seeing if anyone has had any joy with a different kernel.
You will need to know which kernel you are using.

The following command copied and pasted into the Terminal will tell you

open the terminal....ctrl alt T

copy and then paste this command in...

Code:
uname -r
Click on return/enter

write the result down....it is only short

eg
5.4.0-66-generic
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,363
Can you share which kernel driver you are using, open a terminal and then share the output of the following command.
Code:
lspci -v
Then search for the for "Audio" and under that section where it says "Kernel Driver in use:" what does it say? According to this link it is "snd_hda_intel" but it could be different for your system but I just want to be sure.
 
Last edited:

saidtaylann

New Member
Credits
18
Can you share which kernel driver you are using, open a terminal and then share the output of the following command.
Code:
lspci -v
Then search for the for "Audio" and under that section where it says "Kernel Driver in use:" what does it say? According to this link it is "snd_hda_intel" but it could be different for your system but I just want to be sure.
Unfortunately, i am windows fo now. So i cant check kernel version. But already all kernel versions has the problem according to bugzilla bug report. Everyone has the problem for all versions.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,363
Unfortunately, i am windows fo now. So i cant check kernel version. But already all kernel versions has the problem according to bugzilla bug report. Everyone has the problem for all versions.
You give up easy! I'm going to assume your system was using snd_hda_intel when it was installed with GNU/Linux since that link on that github page with the system information also uses that driver. My mediabox uses the same driver and I also ran into this problem some time ago, I was able to fix it by adding the following to the boot parameters.
Code:
snd_hda_intel.probe_mask=0x01
I would think that would have also worked for you since your system most likely was using the same driver.
 
Last edited:

ianhow89

New Member
Credits
7
You give up easy! I'm going to assume your system was using snd_hda_intel when it was installed with GNU/Linux since that link on that github page with the system information also uses that driver. My mediabox uses the same driver and I also ran into this problem some time ago, I was able to fix it by adding the following to the boot parameters.
Code:
snd_hda_intel.probe_mask=0x01
I would think that would have also worked for you since your system most likely was using the same driver.
How does one add that to the boot parameters? I am new, but Have enjoyed all the fun of installing Ubuntu so far, but still have tons to learn. This is the last thing I need to figure out to feel like I have it fully installed.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,363
How does one add that to the boot parameters? I am new, but Have enjoyed all the fun of installing Ubuntu so far, but still have tons to learn. This is the last thing I need to figure out to feel like I have it fully installed.
You can add it to your bootloader configuration, Ubuntu uses grub so you would have to do the following.
1. Open this file for editing: /etc/default/grub
2. Add the parameter to this line: GRUB_CMDLINE_LINUX
3. It would then look like this: GRUB_CMDLINE_LINUX=" snd_hda_intel.probe_mask=0x01"
4. Then update your grub configuration: sudo update-grub
 

gnsouza

New Member
Credits
15
Hi f33dm3bits

In my case, this is the configuration being used
00:1f.3 Audio device: Intel Corporation Comet Lake PCH cAVS
Subsystem: Lenovo Device 3811
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel, snd_sof_pci

I've tried to put the command snd_hda_intel.probe_mask=0x01, but it didn't work. I've attached the hole log. Is there anything else that I could do?

Thanks
Germano Souza
 

Attachments

brickwizard

Well-Known Member
Credits
6,393
you do not say which distro you are using,
If its Ubuntu based then there are a couple of suggestions here...
 

gnsouza

New Member
Credits
15
Hi brickwizard

Sorry. My bad! I've just installed Ubuntu 20.04. Just to give you more context. The problem is internal speaker. If I connect the earplugs, it works fine.

Thanks
Germano
 

brickwizard

Well-Known Member
Credits
6,393
this sounds like a programming error [sorry not my thing] but I did find another Q&A in the ubuntu forums ..BE sure to read the whole thing comments and all before you do anythin
 

brickwizard

Well-Known Member
Credits
6,393
Last edited:

brickwizard

Well-Known Member
Credits
6,393
external-content.duckduckgo.com.jpeg

added https:
Brian
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top