[solved] Asus N61Jv Nvidia Driver Problem

C

CanEzgi

Guest
Hi Guys

i have a asus n61jv notebook. it is contain nvidia GT325m graphic card. i use to OpenSuse 12.2. i installed nvidia graphic card driver after my OS do not start XDM service and OS is open init level 3. i try to start XDM service in terminal but it is not. help me!!!!


i am so sorry but my english is not better.

thanks for help us!
 

Attachments



C

CanEzgi

Guest
first of all i entered init level 3 and added blacklist nouveu driver. second of all i installed nvidia official driver in my graphic card with sh command. latest, reboot my system. and OS is open init level 3 and i do not enter init level 5.
 
D

DevynCJohnson

Guest
On most systems, the GUI can only be executed in runlevel 5. Why are you not using runlevel 5?
 
R

ryanvade

Guest
On most systems, the GUI can only be executed in runlevel 5. Why are you not using runlevel 5?
Not all systems use the same run levels. But a good question non the less..


This notebook uses Nvidia Optimus technology.
"
  • World 1st notebook with NVIDIA Optimus™ Technology, Great Performance, Great Battery Life
https://www.asus.com/Notebooks_Ultrabooks/N61Jv/

Which means you need something to turn the graphics card on/off. I recommend Bumblebee.

http://www.linux.org/threads/nvidia-optimus-on-linux.4415/
 
L

lobo

Guest
The system would have booted to init 5, but most likely the xserver hasn't started, which is why you believe it's booting to init 3.

The most likely reason for this is that you did not configure xorg.

The proprietary VGA drivers need at an absolute minimum an xorg.conf file with a device section. Try creating a simple one as follows:

/etc/X11/xorg.conf
Code:
Section "Device"
        Identifier "gpu0"
        Driver "nvidia"
EndSection
Reboot.
 
C

CanEzgi

Guest
On most systems, the GUI can only be executed in runlevel 5. Why are you not using runlevel 5?

because i switch run level 5. i install driver switching level3 and then i do not switch level 5. this is my problem. :D
 
C

CanEzgi

Guest
The proprietary VGA drivers need at an absolute minimum an xorg.conf file with a device section. Try creating a simple one as follows:

/etc/X11/xorg.conf
Code:
Section "Device"
        Identifier "gpu0"
        Driver "nvidia"
EndSection
Reboot.
i try to your said. my system reduce error count but is not open and stay init 3. :D
 
L

lobo

Guest
I missed ryanvade's post about bumblebee... you will need to remove the xorg.conf and you will need to install bumblebee as he suggests.
 
C

CanEzgi

Guest
i think install bumblebee but i do not know install bumblebee and i do not find to search google in suse 12.2
 
R

ryanvade

Guest
Code:
zypper ar -f http://download.opensuse.org/repositories/home:/Bumblebee-\
Project:/nVidia:/latest/openSUSE_Factory "Bumblebee nVidia
Code:
zypper ar -f http://download.opensuse.org/repositories/home:/Overman79\
/openSUSE_12.2/ "Home:Overman79"
Code:
systemctl enable bumblebeed.service
Remember to add yourself to the "bumblebee" group.
Install the "Linux kernel development" pattern in YaST
Code:
zypper refresh && zypper install dkms-nvidia

Code:
zypper install x11-video-nvidia \
x11-video-nvidia-devel \
nvidia-compute \
nvidia-compute-devel
Code:
zypper install x11-video-nvidia-32bit \
x11-video-nvidia-devel-32bit \
nvidia-compute-devel-32bit
At this point, you might reboot to test that the 'nvidia' driver really is installed and running. Try
Code:
lsmod | grep nvidia, lsmod | grep nouveau/CODE], and [CODE]glxgears
Code:
zypper install dkms-bbswitch && zypper install bumblebee
Here's what I see at this point:
# zypper info bumblebee
... Repository: home:Overman79
Name: bumblebee
Version: 3.0.1-16.1
Arch: x86_64 ....
# zypper info dkms-bbswitch
... Repository: home:Overman79
Name: dkms-bbswitch
Version: 0.5-2.1
Arch: noarch ...

Code:
systemctl enable bumblebeed.service && systemctl start bumblebeed.service
Reboot one more time, and try this:
# lsmod | grep nvidia
# lsmod | grep i915
i915 505525 4
drm_kms_helper 51052 1 i915
drm 272508 5 i915,drm_kms_helper
i2c_algo_bit 13413 1 i915
video 19345 1 i915
button 13906 1 i915
# lsmod | grep bbswitch
bbswitch 13708 0
# # systemctl status bumblebeed.service
bumblebeed.service - Bumblebee C Daemon
Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; disabled)
Active: active (running) since Mon, 28 Jan 2013 12:56:52 +0100; 4h 0min ago
Main PID: 3548 (bumblebeed)
CGroup: name=systemd:/system/bumblebeed.service
└ 3548 /usr/sbin/bumblebeed

Jan 28 12:56:52 wilbur bumblebeed[3548]: [ 725.806621] [INFO]
/usr/sbin/bumblebeed 3.0.1 started


Then continue with my tutorial at "Configuring Bumblebee"
 
C

CanEzgi

Guest
i do not add this repos in terminal but i add in yast manager. And

systemctl enable bumblebeed.service


i do not run up command.

systemctl start [restart][stop] bumblebeed.service

i use to up and worked. :D

THANKS FOR HELP EVERYBODY
 
Last edited:

Members online


Top