[SOLVED] Black screen with blinking square on boot


New Member
May 2, 2021
Reaction score
arch linux, Kernel: 5.12.6-arch1-1

...step by Step what I did in the session until the OS hit the fan:
- Login into my profile
$ sudo nano „/usr/share/thumbnailers/ffmpegthumbnailer.thumbnailer“
- replaced from MimeType=app... downwards with
- removed totem.thumbnailer file from the folder with
$ sudo rm -f totem.thumbnailer
- opened nautilus manager to see if any changes in previews were made
- the nautilus manager window closed all 5 seconds frequently
- opened pamac GUI to remove ffmpegthumbnailmaker but it took ages to open the program and the provided pic above shows what happened
- ran
$ pamac -Rns ffmpegthumbnailer
$ sudo pacman Syu
( tons of mirrors failed but it made it trough after a while)
$ reboot
- unencrypted my OS-Disk and getting a blank black screen with blinking square icon.

I can change ttyu but thats it.

it must have been a small change during session that broke it so, I guess its something small to fix it aswell?

I hope someone can reach out to me and help....thanks!
Last edited:

removed totem.thumbnailer file from the folder with
What folder? $HOME? I'm not sure, but I think you might've just deleted your $HOME entirely. Running stuff like
rm -f
and specially with -f = force without a warning, can lead to disastrous results. You can try creating a new user from a TTY and see if you can log in to Gnome from that account. If you do, you can try and recover your other account from the new one.
Can you clarify where you are with this; the title is boot error , blinking cursor suggests no output , no >grub prompt i.e nothing.

i'm probably not goingto be much help having recently switched to Arch from Slackware but..

i've played with some worse case scenario for Arch and for instance booting a liveOS from usb, mouting root partition to /mnt chroot /mnt and cd to /mnt

- i did it from Slackware live i found i could evoke journactl to look at boot log etc. If you used Arch install iso then you could also use iwctl to connect to internet maybe to install xorg , DEsktop if needed etc , add a new user :

something like:

# useradd -m -G wheel -s /bin/bash <username>

# paswd <username>

you can fix grub after also mouting (if its uefi) efi partition to /mnt/boot. i tried re-installing grub on EndeavourOS( via LiveOS from usb) before switching to Arch vanilla and it worked.
The nvidia kernel didn't update properly because mirror.list failed
so, I had to install reflector and choosed the 5 fastest downloads as mirror, to get my whole GUI showing up properly again.
The Country , where i was few weeks ago (sub sahara ) had zero mirrors for the Country so i just went here : https://archlinux.org/mirrorlist/ and generated a list from likely candidate Countries eg Kenya . Then a manual edit of /etc/pacman.d/mirrorlist pasting in - worked well