SOLVED: Caps/Hyper behavior inconsistent

Sueno1123

New Member
Joined
Feb 19, 2022
Messages
19
Reaction score
5
Credits
166
THIS HAS ALREADY BEEN ANSWERED ON ANOTHER FORUM.

System info: Manjaro KDE, Intel i5-6300U, Intel HD Graphics 520

I’ve been trying to solve this for weeks now. Before I switched to Linux, I had wired AutoHotkey to replace the function of the Caps Lock key to become a modifier (e.g. caps + a would run a certain application, etc). Now that I’m on Linux, I changed the behavior of caps from the system settings menu to become “make caps lock an additional hyper”. I then set a custom shortcut for caps + a to run the command:
Bash:
rofi -show run
This only works half the time. When I restart the computer, the option is still checked but it doesn’t work at all. I have to unswitch it and switch it again, and that freezes the system for a minute and sometimes doesn’t even work. Also, even when it’s working, this supposed hyper key actually functions like a super key (windows key), opening the menu when pressed.

I use fcitx5, and I’ve tried to mess with xkb (specifically by adding "caps:hyper" to /etc/default/keyboard, which didn’t work at all.) I’ve tried resorting to the ArchWiki X Keyboard instructions, but they’re waaaay over my head.

P.S. I’m not sure if this is relevant, but sometimes fcitx5 shows 2 icons on the system icons toolbar, and restarting fcitx5 from the drop menu freezes the computer for approximately 10 seconds.

Thank you in advance.
 
Last edited:


Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,552
Reaction score
4,655
Credits
33,740
Thanks for letting us know it has been Solved.

Welcome to Linux.org
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top