[SOLVED] Dummy output / No audio after OS update

graphicalx

New Member
Joined
Nov 4, 2022
Messages
3
Reaction score
2
Credits
39
Hi everyone, new convert here. Shifted from Windows to Ubuntu 2 months ago, sound was working in the beginning but stopped after a while. I couldn't figure out what was the problem, posted in a lot of detail on AskUubuntu: https://askubuntu.com/questions/1432056/sound-not-working-on-elitebook-850-g5-on-ubuntu-22-04-1

Then moved to Pop OS! and everything was great for a month until today or yesterday. This time I knew I did 3 things in the period it stopped working:
1. Installed an app FSearch (tried uninstalling it, didn't get sound back)
2. Auto-mounted a Windows partition (undid this, didn't get sound back)
3. Installed OS update <- I think this should be the culprit.

/var/log/apt/history.log entries from now since last night:

Code:
Start-Date: 2022-11-03  11:19:53
Commandline: packagekit role='install-packages'
Requested-By: hal (1000)
Install: gir1.2-clutter-1.0:amd64 (1.26.4+dfsg-4build1, automatic), gir1.2-cogl-1.0:amd64 (1.22.8-3build1, automatic), gir1.2-gsound-1.0:amd64 (1.0.3-2build1, automatic), python3-nautilus:amd64 (1.2.3-3.1build1, automatic), gir1.2-nautilus-3.0:amd64 (1:42.2-0ubuntu1, automatic), gir1.2-gdata-0.0:amd64 (0.18.1-2build1, automatic), sshfs:amd64 (3.7.1+repack-2, automatic), gir1.2-goa-1.0:amd64 (3.40.1-2ubuntu1pop0~1649081188~22.04~8042754, automatic), gir1.2-coglpango-1.0:amd64 (1.22.8-3build1, automatic), gnome-shell-extension-gsconnect:amd64 (50-0ubuntu1)
End-Date: 2022-11-03  11:19:54

Start-Date: 2022-11-03  11:23:00
Commandline: packagekit role='remove-packages'
Requested-By: hal (1000)
Remove: gir1.2-clutter-1.0:amd64 (1.26.4+dfsg-4build1), gir1.2-cogl-1.0:amd64 (1.22.8-3build1), gir1.2-gsound-1.0:amd64 (1.0.3-2build1), python3-nautilus:amd64 (1.2.3-3.1build1), gir1.2-nautilus-3.0:amd64 (1:42.2-0ubuntu1), gir1.2-gdata-0.0:amd64 (0.18.1-2build1), sshfs:amd64 (3.7.1+repack-2), gir1.2-goa-1.0:amd64 (3.40.1-2ubuntu1pop0~1649081188~22.04~8042754), gir1.2-coglpango-1.0:amd64 (1.22.8-3build1), gnome-shell-extension-gsconnect:amd64 (50-0ubuntu1)
End-Date: 2022-11-03  11:23:01

Start-Date: 2022-11-03  11:42:02
Commandline: packagekit role='update-packages'
Requested-By: hal (1000)
Upgrade: firefox:amd64 (106.0.1~1666305115~22.04~351138a, 106.0.3~1667234515~22.04~2736bdd)
End-Date: 2022-11-03  11:42:06

Start-Date: 2022-11-03  11:42:41
Commandline: packagekit role='update-packages'
Requested-By: hal (1000)
Install: linux-modules-6.0.3-76060003-generic:amd64 (6.0.3-76060003.202210211149~1666452039~22.04~1891946), linux-image-6.0.3-76060003-generic:amd64 (6.0.3-76060003.202210211149~1666452039~22.04~1891946), linux-headers-6.0.3-76060003:amd64 (6.0.3-76060003.202210211149~1666452039~22.04~1891946), linux-headers-6.0.3-76060003-generic:amd64 (6.0.3-76060003.202210211149~1666452039~22.04~1891946)
Upgrade: linux-system76:amd64 (6.0.2.76060002.202210150739~1666289067~22.04~fe0ce53, 6.0.3.76060003.202210211149~1666452039~22.04~1891946), linux-headers-generic:amd64 (6.0.2.76060002.202210150739~1666289067~22.04~fe0ce53, 6.0.3.76060003.202210211149~1666452039~22.04~1891946), libntfs-3g89:amd64 (1:2021.8.22-3ubuntu1.1, 1:2021.8.22-3ubuntu1.2), ntfs-3g:amd64 (1:2021.8.22-3ubuntu1.1, 1:2021.8.22-3ubuntu1.2), system76-power:amd64 (1.1.23~1661535605~22.04~b9b6342, 1.1.23~1667321125~22.04~4cceb52), linux-generic:amd64 (6.0.2.76060002.202210150739~1666289067~22.04~fe0ce53, 6.0.3.76060003.202210211149~1666452039~22.04~1891946), libssl3:amd64 (3.0.2-0ubuntu1.6, 3.0.2-0ubuntu1.7), linux-image-generic:amd64 (6.0.2.76060002.202210150739~1666289067~22.04~fe0ce53, 6.0.3.76060003.202210211149~1666452039~22.04~1891946), openssl:amd64 (3.0.2-0ubuntu1.6, 3.0.2-0ubuntu1.7)
End-Date: 2022-11-03  11:43:42

Start-Date: 2022-11-04  13:33:44
Commandline: packagekit role='update-packages'
Requested-By: hal (1000)
Upgrade: python3.10:amd64 (3.10.6-1~22.04, 3.10.6-1~22.04.1), tzdata:amd64 (2022e-0ubuntu0.22.04.0, 2022f-0ubuntu0.22.04.0), libpython3.10-minimal:amd64 (3.10.6-1~22.04, 3.10.6-1~22.04.1), libpython3.10-stdlib:amd64 (3.10.6-1~22.04, 3.10.6-1~22.04.1), libpython3.10:amd64 (3.10.6-1~22.04, 3.10.6-1~22.04.1), distro-info-data:amd64 (0.52ubuntu0.1, 0.52ubuntu0.2), python3.10-minimal:amd64 (3.10.6-1~22.04, 3.10.6-1~22.04.1)
End-Date: 2022-11-04  13:33:49

This time I had Timeshift backups from the start, so I can go into recovery, but I want to know how I can fix this without recovery? If OS updates are causing this, going back in time won't help.

I had posted all information in my previous post when I had installed Ubuntu (https://askubuntu.com/questions/1432056/sound-not-working-on-elitebook-850-g5-on-ubuntu-22-04-1) but please feel free to ask anything else

UPDATE: I restarted and on the boot loader there was another option "Pop! OS old Kern" <- I selected this and sound was working! So apparently a Kernal update caused issues? What can I do to avoid / prevent / undo this going forward
 
Last edited:


KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,071
Reaction score
6,928
Credits
65,521
You'll want to resolve the system error. You do not want to keep using an older kernel for long, as the updates to the kernel are mostly security updates. You can try skipping a kernel upgrade, which won't take too long. A new version will come down the pipe and you can try that - after making a backup.

So, for now I'd use the older kernel until a new one comes along. Then, I'd make a backup before installing the new kernel. If you still have problems with sound, then you'll need to start debugging and trying various solutions until something works.
 
OP
G

graphicalx

New Member
Joined
Nov 4, 2022
Messages
3
Reaction score
2
Credits
39
Thank you. I'm just loving how responsive Linux and Pop! OS' shell are. Windows has a way of making even top of the line PCs lag, and you don't even notice that until you move to Linux. Don't make me go back ;p

Would you be kind enough to guide me to some documentation or tutorial that helps me get up to speed on this? I'm a web programmer (and have used Linux as a server) but kernels are not my forte
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,071
Reaction score
6,928
Credits
65,521
I dunno much about Windows these days. So, I can't opine. I will have to get a Windows device sometime soon, as I need it to do some recording tasks.

Anyhow, I'm not quite sure what you want to be up to speed with. You really shouldn't need to do anything with the kernel except to wait and see, backup in hand in case things go pear shaped. Just wait and see... You could try pouring over kernel release notes to see if your device is mentioned. You could also try asking at the vendor's site (as it's reasonably clear that the upgrade hosed the sound).

Other than that, just keep on computing until the next kernel update comes along.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top