(SOLVED) games running slower than a powerpoint slide, any ideas?

OP
D
Joined
Nov 16, 2021
Messages
75
Reaction score
17
Credits
534
Try this first.
[email protected]:~
$ sudo apt install firmware-amd-graphics libgl1-mesa-dri libglx-mesa0 mesa-vulkan-drivers xserver-xorg-video-all
[sudo] password for donnerkebab1730:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
xserver-xorg-video-all is already the newest version (1:7.7+22).
firmware-amd-graphics is already the newest version (20210818-1~mx21+1).
firmware-amd-graphics set to manually installed.
libgl1-mesa-dri is already the newest version (21.2.5-1~mx21ahs+1).
libglx-mesa0 is already the newest version (21.2.5-1~mx21ahs+1).
mesa-vulkan-drivers is already the newest version (21.2.5-1~mx21ahs+1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~
$


already installed
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,447
Reaction score
3,162
Credits
32,251
$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.14.0-4mx-amd64 root=UUID=7fced58d-182d-4348-b980-6b1896a971a2 ro nomodeset quiet splash
Remove the nomodeset from your Grub configuration(or whatever bootloader you are using) and then run update-grub or whatever you use to update your Grub configuration. Then reboot and show the output of inxi -G again?
 
OP
D
Joined
Nov 16, 2021
Messages
75
Reaction score
17
Credits
534
Remove the nomodeset from your Grub configuration(or whatever bootloader you are using) and then run update-grub or whatever you use to update your Grub configuration. Then reboot and show the output of inxi -G again?
i have litralley no idea what bootloader im using but ill try
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,447
Reaction score
3,162
Credits
32,251

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,447
Reaction score
3,162
Credits
32,251
Your system is using Grub as bootloader, can you share the output of the following?
Code:
cat /etc/default/grub
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,447
Reaction score
3,162
Credits
32,251
And share the output of the following as well.
Code:
ls -l /boot/grub
 
OP
D
Joined
Nov 16, 2021
Messages
75
Reaction score
17
Credits
534
[email protected]:~
$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(unset PRETTY_NAME; (. /etc/lsb-release; echo ${PRETTY_NAME:?}) 2>/dev/null || echo Debian)"
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_DISABLE_OS_PROBER=false
#export GRUB_MENU_PICTURE="/usr/share/backgrounds/MXLinux/grub/linen-gradientblu-grub.png"
#export GRUB_MENU_PICTURE="/usr/share/backgrounds/MX18ALPHAWALL.png"

GRUB_THEME="/boot/grub/themes/mx_linux/theme.txt"
[email protected]:~
$

Your system is using Grub as bootloader, can you share the output of the following?
Code:
cat /etc/default/grub
 
OP
D
Joined
Nov 16, 2021
Messages
75
Reaction score
17
Credits
534
And share the output of the following as well.
Code:
ls -l /boot/grub
[email protected]:~
$ ls -l /boot/grub
total 2376
drwxr-xr-x 2 root root 4096 Nov 28 20:45 fonts
-r--r--r-- 1 root root 6876 Nov 28 20:45 grub.cfg
-rw-r--r-- 1 root root 1024 Nov 28 20:45 grubenv
drwxr-xr-x 2 root root 12288 Nov 28 20:45 i386-pc
drwxr-xr-x 2 root root 4096 Nov 28 20:45 locale
drwxr-xr-x 8 root root 4096 Nov 21 03:23 themes
-rw-r--r-- 1 root root 2394108 Nov 21 03:27 unicode.pf2
[email protected]:~
$
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,447
Reaction score
3,162
Credits
32,251
doesnt boot without nomodeset
I missed that, AMD graphics card should be able to boot without nomodeset but some seem to have problems with that. I have an AMD graphics card as well and the only thing I have installed are the kernel and mesa and it then automatically loads the amdgpu driver. Your system should automatically pick up the opensource driver as well since your system isn't doing that the alternative option would be to install the amdgpu-pro driver.
Officialy they the deb packages they provide are for Ubuntu but you could try to see if it works for MX Linux I'm not sure it does but it's worth a try since MX is based on Debian.
 
OP
D
Joined
Nov 16, 2021
Messages
75
Reaction score
17
Credits
534
I missed that, AMD graphics card should be able to boot without nomodeset but some seem to have problems with that. I have an AMD graphics card as well and the only thing I have installed are the kernel and mesa and it then automatically loads the amdgpu driver. Your system should automatically pick up the opensource driver as well since your system isn't doing that the alternative option would be to install the amdgpu-pro driver.
Officialy they the deb packages they provide are for Ubuntu but you could try to see if it works for MX Linux I'm not sure it does but it's worth a try since MX is based on Debian.
nevermind what i said in the message below im still confuesed, what commands am i supposed to use?
 
OP
D
Joined
Nov 16, 2021
Messages
75
Reaction score
17
Credits
534
this may be random but when booting ive just realised that it says *warning* error vgacon disables amd drivers in kernal
 
OP
D
Joined
Nov 16, 2021
Messages
75
Reaction score
17
Credits
534
Download the deb files and try installing it like they show here.
Code:
$ cd ~/Downloads
# For Ubuntu:
$ sudo apt-get install ./amdgpu-install-VERSION.deb
$ sudo apt-get update
[email protected]:~/Downloads
$ sudo apt-get install ./amdgpu-pro-21.30-1290604-ubuntu-20.04.tar.xz
[sudo] password for donnerkebab1730:
Reading package lists... Done
E: Unsupported file ./amdgpu-pro-21.30-1290604-ubuntu-20.04.tar.xz given on commandline
[email protected]:~/Downloads
$
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,447
Reaction score
3,162
Credits
32,251
You need to extract it first.
Code:
tar -xfJ amdgpu-pro-21.30-1290604-ubuntu-20.04.tar.xz
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,447
Reaction score
3,162
Credits
32,251
I can't find the file you downloaded, I must have missed an option. Just download the deb from here and then try installing it.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top