[Solved] GPU Drivers in a VM

DexTheDog

New Member
Credits
70
Hello, I just switched to Linux mint cinnamon. I still have a win 10 drive for gaming but I am trying to go full Linux though and game on a win 10 VM. Does anyone know how do get a GPU to show up? And I am aware Wine is a thing.
 


f33dm3bits

Gold Member
Gold Supporter
Credits
16,014
Do you mean you want the graphics card in your Windows 10 system to show up in your vm so that you can use it for gaming or something like that?
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
16,014
You will need a second graphics card to use for your vm using pci-passthrough because your Windows 10 system is using your graphics card your vm can't use it. Currently your vm is using a virtual graphics card which works but can't be used for graphic intensive things such as playing videos or gaming.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,014
But if you just want to see what graphics driver your vm is using you can just do the following from within your vm.
1. Open a terminal
2. run: lspci -v
3. Look for the VGA section
4. Where it says "Kernel driver in use" that is the driver it is using for your virtual graphics card for your vm.
 

DexTheDog

New Member
Credits
70
I am sorry if I said this wrong but the VM is running on a Linux Mint Cinamon Drive and the os on the VM is Win 10. I don't think it would make a difference but I would just like to specify.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,014
I am sorry if I said this wrong but the VM is running on a Linux Mint Cinamon Drive and the os on the VM is Win 10. I don't think it would make a difference but I would just like to specify.
Yes I mixed what I meant to say around, do you want the virtual graphics card drivers for your Windows system? If not you will have to look at the link @Tolkem provided depending on which graphics card your Mint system has.
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
15,029
I don't use passthrough for anything, so had no idea until I read @Tolkem's link.

Linux host: Drop PCI passthrough, the current code is too incomplete (cannot handle PCIe devices at all), i.e. not useful enough
Good job, Oracle...

"It was more or less broken for modern graphics cards. Instead of fixing that, we just ripped out the option."
 

Tolkem

Well-Known Member
Credits
5,208
I am sorry if I said this wrong but the VM is running on a Linux Mint Cinamon Drive and the os on the VM is Win 10. I don't think it would make a difference but I would just like to specify.
We understood that correctly. What virtualization software are you using? Virtualbox? VMware? QEMU? If virtualbox, you can't use pci-passthrough since support for this feature was dropped for Linux hosts. https://www.virtualbox.org/wiki/Changelog I'm adding some links for you as a starting point:
If you're using Vmware, read here https://thevirtualboi.com/2018/10/03/how-to-configuring-gpu-passthrough-on-a-virtual-machine/
if QEMU read here https://mathiashueber.com/windows-virtual-machine-gpu-passthrough-ubuntu/
If your GPU is an Nvidia one, read here https://docs.nvidia.com/grid/5.0/grid-vgpu-user-guide/index.html
You should do your own research as well to clarify and expand your understanding on the concepts, techniques and tricks explained in those links. I myself haven't used GPU/PCI passthrough so ... this is all the advice I can give. Good luck! :)
 

Tolkem

Well-Known Member
Credits
5,208
I have seen this. But I am using wifi for a Proxmox VM. (PVE 6.2)
However I only have one video card, so I haven't tried video.
Promox uses KVM and containers, and as far as I've read, KVM does support pci/gpu-passthrough. No idea whether containers do too. That link refers specifically about virtualbox dropping support for it in Linux hosts.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online

Members online


Top