[SOLVED]Help correcting gimp font size

Dropinthesea

New Member
Joined
Oct 22, 2020
Messages
1
Reaction score
0
Credits
16
I'm using X1C gen 7 4k, xfce, lightdm, uefi & grub install

Arch wiki wrote:

Gimp 2.10
To fix toolbar icon sizes, update Preferences->Interface->Icon Theme->Custom icon size to huge or other value.
If menu fonts are still too small you can update an existing theme by copying it from /usr/share/gimp/2.0/themes into ~/.config/GIMP/2.10/themes/ and changing gtk-font-name and font_name in gtkrc into something bigger like Sans 30. Then select the new theme from Preferences > Interface > Theme. When copying make sure to rename the new directory into something different from the original name (example Dark > DarkHighDPI).
You can also try using gimp-hidpi (installation instructions are outdated and refer to version 2.8, in Gimp 2.10 the theme should be installed into ~/.config/GIMP/2.10/themes/)
I've done all the above to no avail, nothing changed. I'm not sure where to go from here.

What I did exactly was:

I changed the settings in preferences and made the icon size huge. Then I made a new directory.

Code:
mkdir ~/.config/GIMP/2.10/themes/DarkHighDPI

From within

Code:
/usr/share/gimp/2.0/themes/Dark

I copied two files

Code:
sudo cp -r gtkrc ui ~/.config/GIMP/2.10/themes/DarkHighDPI

4. I edited the gtkrc file with sans 30 for both the gtk-font-name and font_name

5. Then from within the gimp program again I changed the theme settings to DarkHighDPI

6. rebooted my laptop started gimp, still no change.

7. I restored a timeshift backup to revert all changes I had made.

Totally my mistake. When I was editing the gtkrc file I didn't notice that it was commented out.
 
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top