Solved [SOLVED] Kinetic Kudu - Possible Problems With Timeshift GUI

Solved issue


Staff member
Gold Supporter
Apr 30, 2017
Reaction score
This thread may be of particular importance to David G. @KGIII and Chris G. @guiverc , as they are both on the Lubuntu/Ubuntu team.

I have been working for the past 2 weeks plus on an issue with Timeshift's GUI falling over (whether creating or deleting a snapshot) on Arch-based distros and openSUSE-based distros (such as Gecko). Under Arch, it relates to a package known as glib2 which is not a part of Timeshift itself, but shakes hands with it.

As I understand it, Arch are aware of this issue and are working on it upstream - more for Arch-based users very soon.

The Arch issue relates to an upgrade form the 2.72 series to the 2.74 series.

Now, what about Ubuntu/Lubuntu and so on?

If I am not mistaken (and David or Chris can correct me if I am wrong), the Canonical equivalent is libglib2.0-0, currently on maybe 2.72.1-1, and that, with 'Kudu' it will go to the 2.74 series.

If, as I suspect, there is a feature freeze on changes to the Kudu model now in place, that may or may not impact on whether they can get a handle on this in tome for the release of Kudu due 20 October.

Fedora users may also be affected, with their release of Fedora 37 due 18 October, just days away.

Linux Mint users should not worry too much yet, as Mint 21.1 should not be due until 5 January or so, but there is a possibility that if they pick up on some of the Kudu versions between times, your Timeshift GUI will be affected adversely. Taking and restoring snapshots via Terminal is fine, and works under the updated Glib packages, but many people would rather use the GUI.

I am currently installing the daily build of Lubuntu, and once operational, I can check it for problems. Likely on my tomorrow.


Chris Turner

Sorry I'm too tired (should have already turned this box off!) to think clearly, but I suspect I've seen folks on kinetic (22.10) ask questions on the issue you mention, but as I don't use timeshift (and Lubuntu doesn't ship it) I've just moved on, and not paid any attention sorry. shows package is 2.74.0-2

Sorry I can't offer anything though.

If you discover issues, especially if you have fixes, I can add a link on Lubuntu's discourse with a link to this site or page, should users have issues & discover our discourse seeking answers.

Ubuntu kinetic kudu is in Final Freeze -
As mentioned above, we don't ship with it by default. I would think a link on the Discourse would be about as good as we're going to get. I'll try to keep an eye on it. If @guiverc doesn't notice, I'll do my best to remind him.

I'm having network connectivity issues today.
Thanks fellas.

If you discover issues, especially if you have fixes, I can add a link on Lubuntu's discourse with a link to this site or page, should users have issues & discover our discourse seeking answers.

Yes, please.

Also, should I be reporting on this to


in this regard?

While Timeshift does not ship with Ubuntu, it is in your repositories, and further, the fault is not to do with Timeshift, but with libglib2.0-0 v.2.74.0-2, which is both in your repositories, ships with Ubuntu, and is listed as supported.

...especially if you have fixes...

I do, or rather a workaround, and I am about to apply to and test the Lubuntu Daily I have.

The workaround involves downgrading the new 2.74.0-2 to Jammy's 2.72.1-1 and then run Timeshift.

I'll report back once I have tested it.

Sourced out libglib2.0-0 v.2.72.1-1 from, and installed it using


sudo dpkg -i libglib2.0-0_2.72.1-1_amd64.deb

...rebooted, and ran Timeshift, took a snapshot and it ran fine.

My next step is to blow away Lubuntu and restore it with the snapshot, as that is the best way of testing the efficacy of a system restore product.

As a part of that, it will re-generate grub, which for me and my 78 distros can take an additional 35 to 45 minutes to perform (58 minutes with Lubuntu, its os-prober is a little slow), so I may not report back until my tomorrow.

BTW I note that I failed to report above that under the 2.74.0-2 version of libglib2.0-0 that ships with kinetic, Timeshift runs for maybe a minute and then the GUI falls over. Rsync continues for another 3 - 5 minutes (output of top) and appears to finish, but the resulting snapshot does not appear in Timeshift's GUI interface, yet you are still robbed of, in my case, 8.7 GB, and the snapshot is incomplete.

I'll get this sequence all in order when I cover it at my Timeshift thread, regrets.
Results inconclusive, it drops me back to a grub prompt (always able to boot a Linux through F12 boot order).

I will have to investigate further on my Sunday.

The best way to report bugs is using the command

`ubuntu-bug timeshift`

where `timeshift` is the package the bug is being reported against, ie. in my example here.

I'd report it against that package myself, and document your belief that it relates to the libglib2.0-0 in your opinion, and feel free to provide your reasoning/logic & any additional notes & links. Ideally you try and be brief in the actual report (only clear required facts) so it maybe better to make the initial report deal only with the actual facts, expected outcome, actual outcome etc, then add the additional detail & more links in a subsequent comment on the same report.

For general clues on reporting bugs, please refer

If a bug triager, or developer confirms the issue relates to the libglib2.0-0 package, the filed-against package can be easily changed, but I'd expect the issue to have occurred in more than just `timeshift` before I'd blame the library (so far we only have timeshift or the user-app being mentioned).

FYI: I've used Ubuntu references only ^ which is common for me, as I actually see Lubuntu as a Ubuntu system. Lubuntu's wiki on bugs can be found at but other than a specific Lubuntu table (LXDE/LXQt conversion; very out-of-date, but I'm loathe to remove it!), some additional clear notes - it doesn't differ.

Thanks (sorry for delayed response..)

Additional detail (I was replying to what I'd read thus far).

When an app closes/crashes, I'd expect to see a crash file under `/var/crash/`. Look there, and if you find one, use

`ubuntu-bug /var/crash/name.of.crash.file.crash`

That may result in the same detail (if crash was the same package), but if it's reported as a crash in another package (such as the library itself), the `ubuntu-bug package` command won't upload & link that detail.
Last edited:
Hey, Chris ta very much for taking the time on your Sunday to provide the above detail.

I will do so.

I used the screenshot generated using the older package to restore the daily build. Initially it did not reconfigure the grub menu sufficiently to boot from (as mentioned above), although it could be booted from an updated menu of another (in this case, Arcolinux). So I restored again, and checked a box in Advanced options in Timeshift to rebuild initramfs and that worked fine.

So the fault definitely (IMO) lies with the 2.74.0-2 version of libglib2.0-0 , and and under Arch, glib2.

This will affect every single 'buntu-based distro that ships with this package, and include eg Pop!_OS , Linux Lite, and so on - all, that is, where the user installs Timeshift (and with Linux Lite, it ships with it).

I have yet to investigate how it affects Debian and direct derivatives such as MX-21 and so forth, also to check my Gentoo-based Calculate.

Busy times, but I will get onto reporting to Ubuntu, and then on to Mint's Clement Lefebvre.


Chris Turner

BTW - one of our own Members, @Oldhabbits found this issue in his Manjaro a day or two before I found it in my own. He reported it to Manjaro, and through that avenue, I understand that the Arch people are working upstream on glib2.

I wonder if he could oblige us with letting us know here if he gets and new developments in that regard?

TIA (thanks in advance) @Oldhabbits
I wonder if he could oblige us with letting us know here if he gets and new developments in that regard?

Scratch that bit for now.

Maker of Timeshift Tony George, notified by one of the people at Manjaro, has stepped up to the plate and released a new version today, 16 October, that will likely address the issue. He has merged with it changes made by Linux Mint, whom recently took over the stewardship of Timeshift.

I am in Manjaro KDE now (coincidentally the same as used by @Oldhabbits ) and am running downloads.

I will report back once I have established the efficacy or not, of the new version.

Still waiting (grub is updating) but notes from Tony's website include the following



teejee2008 released this 12 hours ago



  • #937: Fix crash on ArchLinux and Ubuntu 22.10 Kinetic
  • Don't show a message when unmounting temporary mount points
  • Remove unused code and functions
  • Use -Os for compilation instead of -O3
  • Merge some changes from the Linux Mint branch I was on the money with the 2.74.0-2 version of libglib2.0-0, and there will still be ramifications, until either the new Timeshift is available under the 'buntus, or the 2.74.0-2 version of libglib2.0-0 is modified to remedy.

On my Arch-based distros, I am glad I have Rolling Release.

We're feature frozen at the moment, due to a new release coming out soon.

Also, with timeshift, I think that may have to be updated at Debian first and then trickle down to Ubuntu? I don't believe there's an Ubuntu-specific version from checking apt policy.

This is outside my wheelhouse, I'm largely just a tester. But, I think it goes to Debian first and then gets synced with the Ubuntu Universe repository. I don't do any packaging.

I had considered learning how and some new user jumped in and started learning the ropes. They're a machine and all sorts of gung ho - for which I'm grateful. It does mean that I don't really need to learn packaging - at least not until they burn out.

It's also about time to renew my membership. I'm gonna have to look that up.
I will report back once I have established the efficacy or not, of the new version

Sorry for the late reply, I have been ill last week, feeling better now.
The new timeshift version we received in Manjaro unstable a while ago seems OK, is now in Testing repo and will soon land in stable. But I'm wondering why Debian unstable/sid still made no effort to address this problem. My Bookworm setup still have the issue at hand ! :-( It is fortunate the problem does not manifest itself through the CLI...
G'day Eddy, hope you are on the mend. :)

I don't know about Debian Sid, but Jas @JasKinasis uses it, and maybe Alan @arochester who is also a Global Mod over at Debian may have some ideas.

The rest of Debian Bullseye and those based on it are using the 2.66.8-1 version of libglib2.0-0 which does not suffer the issue.

Linux Mint, as new custodians of Timeshift, are now rolling out the version as according to what Tony George cobbled together for Manjaro last Sunday. In Mint it is named Timeshift


Edited typo in last line, should have been Timeshift
Last edited:
I’ve been using Debian stable the last few years. But I don’t use Timeshift, so I really couldn’t comment!
Just an update, I have established that by updating the Lubuntu Daily Build from 14 October with the Timeshift .deb supplied from the link I provided at #15, it works fine for taking a snapshot, deleting a snapshot and restoring from a snapshot.

I am writing this during an install of Lubuntu 22.10 'Kinetic Kudu' as released the other day, and will perform the same from there and report back.

Eddy, I have an idea or two on Sid and will check them out soon, but as you say

It is fortunate the problem does not manifest itself through the CLI...


Edited, corrected version number.
Last edited:
Eddy, I have an idea or two on Sid and will check them out soon, but as you say
Hallo Wiz, thanks for your efforts, no rush though as Manjaro is actually my main OS.

I'm not sure I could install a Ubuntu ppa onto Debian without degrading to an debian-frankenstein system ;-) or maybe I could get a bunch of dependency errors while trying to install the timeshift.deb file.
For the moment I'm hanging on, sooner or later the guys of Debian will release a updated version of timeshift, I'm sure...

Greetz, Eddy
Agreed, thank heavens for Tony George stepping up to the plate, Manjaro and the 'buntus are OK now. rush though...

No worry, I don't rush, bad for the blood pressure... and Wizards move in a different time spectrum. ;)

I have about 8 Debian derivatives so I can make a Franken-Deb of one testing, and still get it back if I need to.

Benefits of multi-multi-booting. I can't really be down unless the power grid falls over.

Benefits of multi-multi-booting. I can't really be down unless the power grid falls over.
Exactly, that's the reason I keep Debian on my system, as backup to start from in case Manjaro goes south after a update ! :)
Both are using the same data-set (as in personal documents, email, music, video's) and both are taking backups to different locations. I think I'm covered against the dev's... :D