Solved [SOLVED] Kinetic Kudu - Possible Problems With Timeshift GUI

Solved issue
I am writing this during an install of Lubuntu 22.04 'Kinetic Kudu' as released the other day, and will perform the same from there and report back.

Just to fix my confusion, 'cause I might be terribly confused, do you mean 22.10?

Oops, ta for that, will edit. :oops:

The end of this drama under the 'Kinetic Kudu' new releases was in sight once I sat down to my laptop this morning, having installed Lubuntu prior to closing down last night.

Here are my notes, if you can follow them.

Oct 26, 2022, 09:23:34

chris@lubuntu-kudu-WD:~$ apt policy timeshift
Installed: (none)
Candidate: 22.06.5-1
Version table:
22.06.5-1 500
500 kinetic/universe amd64 Packages
chris@lubuntu-kudu-WD:~$ apt policy libglib2.0-0
Installed: 2.74.0-3
Candidate: 2.74.0-3
Version table:
*** 2.74.0-3 500
500 kinetic/main amd64 Packages
100 /var/lib/dpkg/status

sudo apt -y install timeshift

... installs Timeshift 22.06.5-1 from the Repositories.

I configure that to my liking, which sets preferences in

App config saved: /etc/timeshift/timeshift.json

I then run

sudo timeshift-gtk

which will launch the Timeshift GUI but with a Terminal underlying it that will capture the error I know will follow.

I select create snapshot and it starts running. Underneath the GUI, the Terminal session reflects the following.

Creating new snapshot...(RSYNC)
Saving to device: /dev/sdc47, mounted at path: /run/timeshift/6757/backup
Syncing files with rsync...
**7.56% complete (00:15:05 remaining)
ERROR:glib-2.0.vapi:1550:string_replace: code should not be reached
Bail out! ERROR:glib-2.0.vapi:1550:string_replace: code should not be reached

The GUI has run for only 1:30 and then fallen over and closed, but issuing the command


shows that several instances of rsync, the underlying engine for Timeshift on an EXT4 system, are running, and I let them run to completion, which takes another 6:40, for a total of 8:10, about right.

At the end of the exercise, I have no visible snapshot to which comments can be attached, but the process has gobbled up 8.4 GB of my snapshot storage space. Also, in between, I had to reboot, because the Timeshift GUI would not allow me to enter and get those figures.


After rebooting and getting those figures, I launch a new instance of Terminal and issue the following command

chris@lubuntu-kudu-WD:~$ time sudo timeshift --create --comments "Lubuntu 'Kinetic Kudu' safety snapshot (full) on /dev/sdc32 WD - generated from CLI"
[sudo] password for chris:
Mounted '/dev/sdc47' at '/run/timeshift/7599/backup'
Creating new snapshot...(RSYNC)
Saving to device: /dev/sdc47, mounted at path: /run/timeshift/7599/backup
Syncing files with rsync...
Created control file: /run/timeshift/7599/backup/timeshift/snapshots/2022-10-26_11-16-18/info.json
RSYNC Snapshot saved successfully (454s)
Tagged snapshot '2022-10-26_11-16-18': ondemand
Removing snapshots (incomplete):
Removing '2022-10-26_10-36-15'...
Removed '2022-10-26_10-36-15'

Found stale mount for device '/dev/sdc47' at path '/run/timeshift/7599/backup'
Unmounted successfully

real 9m11.280s
user 0m0.038s
sys 0m0.057s

That process comprised about 8 minutes for taking the Timeshift snapshot, and 1 minute 10 seconds for deleting the incomplete snapshot taken previously.

If I were to open the Timeshift GUI again, I would find my new snapshot in place, with attached comments.

However I cannot use that snapshot from within Lubuntu to restore, because it will fall over again, and brick the system.

2. So the option is there to use what Tony George, author of Timeshift has kindly made available to us, and that is a new Timeshift.

In my case, I already had a copy of the .deb on hand from testing it successfully with Lubuntu's Daily Build from 14 October, so I just copied that across to my Downloads folder and installed it from there.

Other than that, if you need it or want it, as mentioned previously, you can go to

and download it. Be sure you get the one for your version.

I installed the new Timeshift, launched it, deleted the snapshot I had made from Terminal, and created a new one in its place.

All good, and I know the snapshot is valid to perform a System Restore, because that worked for the Daily Build when I tested it on that.


  • Users who install the 22.10 point release of Ubuntu Desktop, Ubuntu MATE, Lubuntu, Kubuntu, Xubuntu and so on who also wish to install Timeshift will not be able to run the GUI (graphical point and click) side of Timeshift successfully, without taking steps such as I have taken. A Timeshift snapshot launched at the Terminal is unaffected. The same applies to deleting a snapshot or restoring from a snapshot - no go with the GUI but OK at Terminal.
  • The culprit is a package known as libglib2.0-0 version 2.74.0-2, released in September 2022.
  • This will also apply to any Linux Distro that is based on Ubuntu 22.10 and uses libglib2.0-0 version 2.74.0-2.
  • I have chosen for now not to report this as a bug (but thanks to @guiverc for directions on how to) because the problem likely lies further upstream with the makers of linglib, which I think may be GNOME. I will look into that.
I will place a SOLVED on this Thread for now, and will provide more details on how it affect other Distros from different Families over at my Timeshift Thread, in the coming days.

Chris Turner
@Oldhabbits - Eddy, once I get my breath back, I will take a look at that issue with Debian Sid and either include it over at my Timeshift Thread, or as a separate thread in our Debian subforum.


A Special Warning on Deviating from my Remedial or Workaround Measures.

Do not think that downgrading libglib2.0-0 version 2.74.0-2 to an earlier version will solve your problem, it won't.

I tried it, and found it causes problems you don't want. ;)

I tried it, and found it causes problems you don't want. ;)
Yes indeed, already been there, tried that... and failed miserably !
Cheers, Eddy
Always welcome Chris. Glad to help the community.


(I suggest jumping down the the summary in this post if you don’t want to re-read the whole thread)

at the link suggest I am somewhat loquacious? Surely not.



Members online

Latest posts