[SOLVED] Need lightweight distro suitable for old RCA tablet


Jun 25, 2020
Reaction score
I have an older RCA Voyager III tablet that does have Android installed. But it also has several Google apps and programs that I do not like. Trouble is that the tablet only has 10.5 GB of memory and 29.24 GB available on a micro USB card. Somewhat slowly I am learning the Linux language. My main computer, a Dell desktop that used to have Windows 10, has been converted to Ubuntu 20.04.2 LTS and I am liking what I am seeing using this OS. I would like help finding a distro that could be installed on the tablet, probably via USB connection or via Bluetooth, and that would not take all of the available space. Thank you, Jim43

Hi Jim43,

I really don't know much about distros that work well on tablets, but from my really short research, it looks like an Ubuntu system might work for your tablet. I don't have much time today to do an in dept research, but it could be a system to choose from. I will also apologize for my answer if it was too obvious and or useless :p
Ratilaprime, thank you for this reply. And yes, it does at least offer some hope that I will be able to find what is needed to get that tablet working on Linux. Thank you again,
Don't know about hardware issues you might have, but on a Dell Laptop/Tablet with touchscreen, I installed Peppermint Linux and all works. Touchpad, touch screen so far no hardware issues.

The problem may be installation on an RCA. At least the Laptop/Tablet has a hard drive.
Thank you. I will give Peppermint a try. So far, the only way(s) I have found to load anything on the RCA tablet is to use either Bluetooth/WiFi or with a micro USB card. And my luck loading an ISO has been less than what would be desired.
What's the CPU architecture of your tablet? Is it arm? arm64? x86_64?
To be totally honest, I do not know what the architecture of the tablet is. All that I do know is that the tablet is an RCA Voyager III that is powered by Android, or has the Android OS instead of any of the other systems. One slight problem I found with that; When I burn an ISO to the micro USB card and try to boot the tablet, a notice comes up that 'an unrecognized SD card has been inserted.' It then gives the option to get that card ready for use by reformatting it. In other words, there seems to be some code in the particular OS of the tablet that can prevent the introduction of any new OS.
You'll need to know that. You'll need software (and a kernel) compiled for the proper architecture. You can't run AMD64 on ARM64, or a 64 bit distro on 32 bit architecture.

Without that information, you're just wildly stabbing in the dark. Google may know what kind of CPU is in it.
What I now have in mind is to do a full factory reset of the tablet to get it back to something close to 'as new' condition, then give it (gift it) to someone else that would probably get more enjoyment out of it than I would. And this thread can be marked as solved. Thanks to all that have offered suggestions.

Members online