[SOLVED] Set default boot to Ubuntu

chirag_mehta

New Member
Credits
26
I'm a complete novice at Linux, I recently dual booted my pc (MSI bravo 15) with windows 10 and ubuntu 20.04 (windows was pre-installed). (I'm using UEFI secure boot)
I'm unable to set Ubuntu as the os to boot by default.
In grub, ubuntu is above windows boot manager, and it should boot into ubuntu but that isn't the case. Probably because my PC uses some other boot menu.
I'm able to enter into grub menu by clicking f11 at the time of booting up, then selecting Ubuntu.
I found some solution using bcdedit in cmd/powershell as admin, but it didn't work.
Then I tried to change bios settings.
Unfortunately, I wasn't able to find ubuntu in there. the options were
1) cd DVD something ( I don't exactly remember)
2) windows boot manager
3) USB hard disk
4) I don't remember what it was, but I'm almost sure it wasn't useful it had something like I64, some other characters in between.
So, I set windows boot manager at lowest position, still it booted to windows.
What should I do?
Any explanation why bios boot option doesn't list ubuntu even though it does list in when I press f11?
 


$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top