Sound not working on any Linux distro with Zenbook 14 OLED

pokhrelashok2

New Member
Joined
Oct 4, 2022
Messages
8
Reaction score
1
Credits
45
Yup i tried it, didn't work. Using an external speaker until this issue gets fixed. Very frustrating
 


sanjibukai

New Member
Joined
Nov 2, 2022
Messages
5
Reaction score
0
Credits
33
Yup i tried it, didn't work. Using an external speaker until this issue gets fixed. Very frustrating
Thanks!
Well I guess I'll do the same...
The problem with Linux on laptops.. It's that I just distro hop until I found one where everything works..
Then I reinstall properly said distro before actually using it..
Anyway...
 

Jay_Motta

New Member
Joined
Nov 29, 2022
Messages
1
Reaction score
0
Credits
7
Anyone know how to make a .deb package to install this recent kernel update? after installing it crashes when I reboot and apparently I should make through a .deb package in Ubuntu 22.10

My machine is an ASUS Zenbook UX3402z
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,060
Reaction score
6,912
Credits
65,438
Anyone know how to make a .deb package to install this recent kernel update?

From what I can tell, your question hasn't really got anything to do with the existing thread.

You should start your own thread, perhaps in the Ubuntu sub-forum.
 

Azzy

New Member
Joined
Jan 19, 2023
Messages
1
Reaction score
0
Credits
9
You could try the XanMod Kernel - https://xanmod.org/
I run it on my machines latest main kernel is 6.1.7
Did this fix the issue, though? Potentially related, sound issues with other Asus laptops have been fixed by setting a few variables using alsa-tools, as seen here, though the commands you have to run vary from model to model. Perhaps there exists a similar set for the Q409ZA?
 
Last edited:

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
2,023
Reaction score
1,418
Credits
15,003
Did this fix the issue, though? Potentially related, sound issues with other Asus laptops have been fixed by setting a few variables using alsa-tools, as seen here, though the commands you have to run vary from model to model. Perhaps there exists a similar set for the Q409ZA?
The thread you are looking is manipulating files for the kernel at that time 5.7 which in turn was fixed in a later kernel 5.9 I believe at that time - this problem is supposedly fixed in kernel 6.1 - whether it is or not I do not know since I do not have this Asus machine, but only a suggestion for someone to try it who has this machine

My Expirion Linux KDE Plasma is running kernel XanMod 6.1.5 - which you can get here - https://sourceforge.net/projects/expirion-linux/files/
Make a live USB and see if you machine has sound about 2.6GBs in size for the ISO
 

centinela

New Member
Joined
Jan 24, 2023
Messages
1
Reaction score
0
Credits
6
Hola alguien a conseguido algo?, he probado mil opciones y no hay forma de hacerlos funcionar yo uso debian 11 kernel 6.1.0 y aun no e obtenido ninguna solución
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,060
Reaction score
6,912
Credits
65,438
Hola alguien a conseguido algo?, he probado mil opciones y no hay forma de hacerlos funcionar yo uso debian 11 kernel 6.1.0 y aun no e obtenido ninguna solución

Please use a translator. This is an English-only site, as we don't have the resources to translate all the comments.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online


Top