ssh -q issue

[email protected]

New Member
Credits
27
Hello all,

I am installing a software where the software installer requires ssh -q to be executed for the below following commands as pre-requisite check. I did enabled the ssh passwordless. But I when I execute the below commands I am still prompting for the ssh password.
Can you please let me know if anything is wrong with the ssh setup.
when ssh -q command is executed I should not get password prompt..


The user name is infaadm

ssh -q [email protected] "free | grep -i mem"
ssh -q [email protected] "free | grep -i mem" | awk '{print $2}'
ssh -q [email protected] "free | grep -c ^processor /proc/cpuinfo"

Thank you in advance
 


JasKinasis

Well-Known Member
Credits
1,193
The -q option doesn’t stop the password prompt. It only suppresses error/warning messages.

If you want to use ssh without using a password, you need to set up ssh to use a secure, cryptographic key.

Check out Robs video on this topic here:
 


Members online


Latest posts

Top