Solved Stable branch: Error! One or more modules failed to install during autoinstall.

Solved issue

userzero

New Member
Joined
Mar 30, 2020
Messages
18
Reaction score
8
Credits
155
Hello All,

I started getting this kernel build error yesterday on the Stable branch. Not sure how to get around it. Any insight much appreciated.

Thanks Much,

uid:0


Building module:
Cleaning build area...
env NV_VERBOSE=1 make -j8 modules KERNEL_UNAME=6.1.0-18-amd64.....................(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-18-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/525.147.05/build/make.log for more information.
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
dkms: autoinstall for kernel: 6.1.0-18-amd64 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 11
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-6.1.0-18-amd64.postinst line 11.
dpkg: error processing package linux-headers-6.1.0-18-amd64 (--configure):
installed linux-headers-6.1.0-18-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-amd64:
linux-image-amd64 depends on linux-image-6.1.0-18-amd64 (= 6.1.76-1); however:
Package linux-image-6.1.0-18-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-headers-amd64:
linux-headers-amd64 depends on linux-headers-6.1.0-18-amd64 (= 6.1.76-1); however:
Package linux-headers-6.1.0-18-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
linux-image-6.1.0-18-amd64
linux-headers-6.1.0-18-amd64
linux-image-amd64
linux-headers-amd64

/var/lib/dkms/nvidia-current/525.147.05/build/make.log says:

ERROR: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_lock'
ERROR: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_unlock'
make[3]: *** [/usr/src/linux-headers-6.1.0-18-common/scripts/Makefile.modpost:126: /var/lib/dkms/nvidia-current/525.147.05/build/Module.symvers] Error
1
make[2]: *** [/usr/src/linux-headers-6.1.0-18-common/Makefile:1991: modpost] Error 2
make[2]: Leaving directory '/usr/src/linux-headers-6.1.0-18-amd64'
make[1]: *** [Makefile:250: __sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-6.1.0-18-common'
make: *** [Makefile:82: modules] Error 2
 


Thanks for the link strombrg. Looks like Nvidia is aware of the issue at least. At this point I'll just wait and keep reading the boards. My system's not broken in any way, just can't do the kernel upgrade. I can wait for 6.1.0.18.
 
Debian does not include the headers when the kernel upgrades
Make sure linux-headers-6.1.0-18-amd64 and linux-headers-6.1.0-18-common are installed - see screenshot from Synaptic Package Manager
1.png


Also run from the terminal
sudo dpkg --configure -a
 
Thanks for the reply GatorsFan,

I used Synaptic (see below) and see that the 6.1.0.18 selections match the ones in the image you provided above and were already selected as installed. I also ran the command sudo dpkg --configure -a but got the same results as in my above posts. Then again, I may be missing something.

linux-headers.png
 
In case its not installed ... if the user installs the package: linux-headers-amd64, the correct version headers for each new kernel version will be installed along with the installation of that kernel. So, with that package installed, upgrading a kernel will install the headers for it.
 
Last edited:
EUREKA! Thanks everyone for your suggestions, especially GatorsFan. I added the backports repository and successfully installed
6.5.0-0.deb12.4-amd64. Apt upgrade was still hanging and trying to configure 6.1.0.18 though so I used:

apt-get --force-yes remove 6.1.0-18-amd6

Voila! No more 6.1.0.18 hanging and erroring out and now I have:

uname -r
6.5.0-0.deb12.4-amd64


Thanks again!!!
 
Good outcome, @userzero :)

If you don't already have it installed, now would be a good time to install Timeshift and take a snapshot.

Better is to take one before you do kernel changes, and then one after you are satisfied they work satisfactorily.

If/or when you are happy with the outcome, you can mark this as solved, from your first post.

nYSKHvh.png


Cheers

Wizard
 

Staff online


Top