Struggle to boot any kind of linux [nvidia]

Hibrit

New Member
Credits
13
Hello everyone.

First of all I should mention i have tried a couple of distros as linux mint, ubuntu, pop os (nvidia version).
But i even couldn't be able to boot into my bootable usb.
After i try to boot from live usb i got a black screen with no cursor or anything at all.
I strongly suspect that my system is not compatible with linux at all.

I am really stuck at this point.

My system is Dell inspiron 7567
 


darry1966

Active Member
Credits
865
One of the late versions of puppy linux may be the answer and it fits your usb booting criteria.

There are 32bit and 64bit versions. Nvidea can be built if necessary.
Try http://murga-linux.com/puppy/

There is guys like Mike Walsh who can point you int the rifht direction. Good Luck for whatever distro you choose. I might point out that Mike is a Dell Guru.
 

Condobloke

Well-Known Member
Credits
1,413
From @arochester 's link above, the specs of your laptop are :
Processor: Intel Core i7 7700HQ @ 2.8GHz (Turbo to 3.8GHz)
RAM: 16GB x1 DDR4 @ 2400MHz (Kingston)
GPU: Nvidia GeForce GTX 1050Ti (4GB)
BIOS: 1.7.0 (Latest available at the time of writing)
Windows 10 Home pre-installed.
OSs on 256GB Toshiba M.2 SATA SSD

Can you confirm that these are indeed the specs of your laptop ?
If these are the specs, please read the link which our Moderator has provided.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
1,842
G'day all, and welcome @Hibrit :)

Have you been into your setup utility (BIOS) and tried disabling Secure Boot?

There is guys like Mike Walsh who can point you int the right direction.
Brian (@Condobloke ) and Tom (@poorguy ) and I used to work with Mike at another forum. He really knows his Puppy :). And John Murga's murga linux has been around almost since Barry Kauler developed Puppy.

Good Luck

Chris Turner
wizardfromoz
 

sp331yi

Active Member
Credits
2,076
You need a 390.25 nVidia driver for Linux on MX 19.1 64-bit or antiX 19.1 64-bit (8GB RAM) and install either from Control Centre or via the smxi script as root.
OP can most likely get video by appending kernel line in BIOS with 'nomodeset.'

EDIT: see Kernel Parameters, syslinux

ex:
linux /boot/vmlinuz-linux root=/dev/sda3 initrd=/boot/initramfs-linux.img nomodeset
 
Last edited:

jglen490

Active Member
Credits
1,345
Correct. The nomodeset boot parameter is the initial solution to a blank screen with Nvidia in almost any situation. Nouveau doesn't always work right. But once you have the correct Nvidia driver setup, it should be smooth sailing after that.
 



Top