Stuck in (initramfs) BusyBox after unfortunate reboot.

Ifhes

New Member
Credits
68
Hello my friends. New in this forum, but planning to participate and finally get some expertise in this.

I've been a GNU/Linux user for some years now, I've been running Kubuntu 18.XX for about 2 years. I love it and will keep using it forever. Last night things started acting strangely apparently from nothing and everything went bananas after a very unfortunate reboot, attempting to fix everything. More details below.

*My setup*

-HP 12 GB RAM laptop with AMD processor and discrete GPU.
-Running OEM Windows 10 and Kubuntu UEFI.
-I have 2 users, one for academic work and other for programming and related.
-In one of the users I created a Virtual Machine with Windows 7 (64bit) so I could work with Excel and python in a freelance project (because I don't hate myself enough to work only with Excel OR mess with the PATH line in Windows)

*The Issue*

I was working for about 2 days straight on the Virtual Machine and was ready to shut everything off when I noticed right after I closed the VM that I didn't moved the project to the shared folder. So I went ahead and tried to open the VM (Oracle Virtualbox 5.1) again to do so. Then I got some errors and at the same time my sister called and asked me for help with something urgent, so I didn't put much attention on the error and just close it.

After about an hour I returned and tried again, but this time another error came up, it kept saying that some file was missing. I also noticed that I couldn't open any new tab on Firefox and the already opened were not loading, then the same VirtualBox error kept spamming for every action I did, so in a attempt to fix it I decided to reboot the system, couldn't do it from the GUI, so I sudo reboot it.

So after selecting boot partition Kubuntu didn't boot and I got what you can see on the attached image.

It was 3 AM, so I left it and went to sleep.

*What I tried*

First I noticed the ACPI Errors and tried to change the boot parameters on grub, adding acpi=off at the end of the kernel line. It got rid of those errors, but I got other ugly Error -110 usb 1-1 instead and still didn't got pass BusyBox.

Then I tried using pci=noacpi and acpi=steict with no luck.

I then made up my mind and decided to reinstall Kubuntu and just backup all the data using my trusty live Linux USB, but oh surprise!, you can't actually copy .vdi files and since I was the dumbest ever and didn't put my project in the shared folder, my work from now 3 days is stuck there. Please consider this, reinstalling the whole system doing a backup must be the last thing we try, pretty please.

Since I am now trying to fix my original Kubuntu, I tried what is suggested in Here, in combination with what I found in other thread to correctly mount and temporarily change the root system in Ubuntu.

Then after rebooting, I got the same error.

Please help!!!

Note: I just would like to recover my project from the .vdi. Other than that, I don't have any issue in reinstalling everything doing a backup. Many thanks in advance.
 


KGIII

Active Member
Credits
1,383
When you say you can't copy VDI files, why is that?

In VirtualBox, you *should* be able to create a new VM instance and then select the VDI as the existent hard drive in your VirtualBox setup configuration, or after the fact by changing the settings. VB is messed up on this box, so I can't grab a screenshot for you right now. You can see this answer:

 

Ifhes

New Member
Credits
68
Sorry for the delay, I had a surgery yesterday.

I am using the installation Drive of Kubuntu as a Live version of it to do this. I just installed virtualbox 5.2 (the same I was using before everything went kaput). Fortunately I do have the .vbox
 

Ifhes

New Member
Credits
68
I just followed the instructions in the thread you kindly shared with me and this is what I got.

Of course I am already searching for a quick fix, but I don't quite understand if the error is on the filesystem or my early installation of virtualbox on this Live version of Kubuntu.
 

Attachments

Ifhes

New Member
Credits
68
Yes. I already tried that yesterday night, but didn't had the energy to post the result. Today I rebuilt the Virtualbox kernel module using /sbin/vboxconfig, retried the steps in your link and now I just tried to do a new Instance using the same configuration I had in the original Virtualbox. This is what I get:
 

Attachments

KGIII

Active Member
Credits
1,383
Sadly, I have no idea what that error message means. That's a Windows thing? When I copy/move .vdi files, I have never had trouble importing them and using them again. I've never had any issues importing them.

But, you can try accessing the files in the .vdi file. If I understand correctly, you have Windows 10. This is for 7 and I know jack squat about Windows.

 

Ifhes

New Member
Credits
68
Ok, I just realized I wasn't sudoing enought. I just too terrified to do it, but this is Live version, so I just tried it and everything worked well enough. I recovered my project.

Now I'd like to fix my OS, if possible. Thank you for all your support, it really helped :).
 


Staff online

Members online


Latest posts

Top