systemd-sysctl issue after Fedora 37 upgrade


Jul 30, 2022
Reaction score
I have been running Fedora 36 since day one happily and without a glitch. Saw Fedora 37 poping up on my screen and decided why not.. I guess I should have thought twice before proceeding.
I am suffering from the error below. Symptoms are also very sluggish laptop and no internet for the first 2 to 3 minutes.
I have the error below that points to an issue with sysctl having a config on line 47 not being correct. I looked and the 99-sysctl.conf exist but is empty. Me lost at this stage. There is no config in the file.
Renamed '99-sysctl.conf' and rebooted same issue.

Nov 15 22:49:20 rocinante systemd[1]: Starting systemd-sysctl.service - Apply Kernel Variables...
Nov 15 22:49:20 rocinante systemd-sysctl[369]: /etc/sysctl.d/99-sysctl.conf:47: Line is not an assignment, ignoring: net.ipv4.tcp_tw_recycle
Nov 15 22:49:20 rocinante systemd-sysctl[369]: Couldn't write '1' to 'net/ipv4/icmp_bogus_error_responses', ignoring: No such file or directory
Nov 15 22:49:20 rocinante systemd[1]: systemd-sysctl.service: Main process exited, code=exited, status=1/FAILURE
Nov 15 22:49:20 rocinante systemd[1]: systemd-sysctl.service: Failed with result 'exit-code'.
Nov 15 22:49:20 rocinante systemd[1]: Failed to start systemd-sysctl.service - Apply Kernel Variables.
Nov 15 21:49:36 rocinante systemd[1]: Starting systemd-sysctl.service - Apply Kernel Variables...
Nov 15 21:49:36 rocinante systemd[1]: Finished systemd-sysctl.service - Apply Kernel Variables.

I just installed 37 on 2 systems. One was fresh install, one was update. I dont see this.
I am curious, do you have chkconfig installed?

Did you look at the file ?
'chkconfig' seems to be installed.
.net/ipv4/icmp_bogus_error_responses --> where should I be looking ? 99-sysctl.conf is empty. There is no conf inside of it.
Also Fedora 36 was extremely quiet. Fedora 37 is extremely noisy. My Laptop (Fan) ramping up even with the slightest operation on the machine: ie, some light internet.
Trying to do some work this morning and the noise of the Fan with Fedora 37 is unbearable. I should have broke my legs instead of upgrading to F36 !! Never had this with Fedora 36
Last edited:
Took a sysctl conf file off the internet and copy and pasted into my own sysctl file. I figured, it apparently is looking for some configuration into that specific files. Since mine was empty it did not make much sense. Now its not empty anymore. Made sure that the config its giving error on is not present on the file 'ipv4/icmp_bogus_error_responses'. Ran 'sysctl -p'. Config came back Ok. Rebooted and still the same errror message comes up. I am at lost.
Could it be that the config file sysctl.conf is somewhere else ? Makes no sense at all but I don't understand what is going on.
When I check the status of 'systemd-sysctl' its alive. I do a restart of the service and have no issue. weird..
Renamed the file from 99-sysctl.conf to 20-sysctl.conf. Still the system is looking for 99-sysctl.conf.
Last edited:
@Earthworm4478 , G'day.

Do you run under EXT4 or BTRFS?

I will be installing in the next day or so, but it will be under EXT4 so I can use that version of Timeshift.

Also, 36 still has support until around 15 May next if you want to put that back on.

Chris Turner
Default settings. I think that means BTRFS
Can't go the route of moving back to F36. Don't have a backup (I know).
Have new issue with Fan ramping up with F37. Sounds like I am in for a Fresh install
I would have lovedbeing able to understand why F37 is looking for 99-sysctl.conf when there is none in my system before the fresh install. For the sake of learning something ...
Last edited:
Thx. Did that but no issue is resolved.
Still with the same damn error message from systemd-sysctl. I think it going to remain a mistery.
What does your 99-sysctl.conf look like, mine is a symlink to ../sysctl.conf and just contains some comments. The only other explanation is that "net.ipv4.tcp_tw_recycle" might be included in /usr/lib/sysctl.d and you can run "systemd-analyze cat-config sysctl.d" to see your current config to see if one of the things mentioned in your error messages is dumped. If not sounds more like something went wrong during the upgrade process, I upgraded 3 of my systems from Fedora 36 to 37 without any issues.
Thanks guys for your replies.
Faced with other issues and one being simply unbereable (fan ramping up) on Fedora 37. Not being able technically and not having the time to go through troubleshooting, I moved away from Fedora 37 for the moment and slapped Ubuntu on my rig.
Faster to fix issues when you simply can't troubelshoot due to lack of time :)
Will revert back to Fedora 37 when things settle I guess. My experience on Fedora 36 was amazing and priceless. Install OS (default settings) and use it. No glitch, no issues, no nothing. Just worked !!

PS: I just realized that probably someone like me do not need a rolling release risking what happened with Fedora 37 and evey upgrade. Would Ubuntu make more sense ? LTS kernel and stable as a rock. I am a trader. When I do not work, I do emails, watch movies and youtube and that is it. Trading due to charting can be GPU intensive, would Ubuntu suits ?
Fedora standard is not a rolling release. Fedora Rawhide is the rolling release version.

Ubuntu is pretty robust, so is Linux Mint.