• We did not send an email asking for donations - please read this post.

There's some bug in Ubuntu Wifi that keeps shutting it off

CrazedNerd

Well-Known Member
Joined
Mar 31, 2021
Messages
833
Reaction score
333
Credits
7,108
I thought it was a signal issues so i bought another node for my mesh system, but it's definetly some Ubuntu linux bug that just randomly shuts off the internet. It may or may not show it in the corner logo (when it does, the wifi becomes a question mark...), but the internet fails to function at random times.
 


Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,167
Reaction score
2,058
Credits
23,570
can you plug in your wifi and run inxi -Nn and post back the result
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,292
Reaction score
1,084
Credits
9,279
Is network manager power save turned on? If it is turn it off that usually will cure the problem of turnoffs.
To find out issue this command in a terminal.
Code:
iwconfig
you get an output like this
Code:
lo        no wireless extensions.

enp0s25   no wireless extensions.

wlp3s0    IEEE 802.11  ESSID:"1970x2" 
          Mode:Managed  Frequency:5.765 GHz  Access Point: 3C:84:6A:43:3A:8B   
          Bit Rate=780 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=67/70  Signal level=-43 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:43   Missed beacon:0
If it says Power Management is on turn it off by doing this
open your favorite text editor with root priviledes (maybe gedit) and
open this file
Code:
/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
By Default you should see a line like this:
Code:
[connection]
wifi.powersave = 3
change the = 3 to = 2 save and reboot.
Then issue the command
Code:
iwconfig
again
and the line Power Management should say off.

See if that solves the problem.

If it does not you need to look elsewhere and you can change the setting back to 3 to turn it back on.
 
OP
CrazedNerd

CrazedNerd

Well-Known Member
Joined
Mar 31, 2021
Messages
833
Reaction score
333
Credits
7,108
Is network manager power save turned on? If it is turn it off that usually will cure the problem of turnoffs.
To find out issue this command in a terminal.
Code:
iwconfig
you get an output like this
Code:
lo        no wireless extensions.

enp0s25   no wireless extensions.

wlp3s0    IEEE 802.11  ESSID:"1970x2"
          Mode:Managed  Frequency:5.765 GHz  Access Point: 3C:84:6A:43:3A:8B  
          Bit Rate=780 Mb/s   Tx-Power=22 dBm  
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=67/70  Signal level=-43 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:43   Missed beacon:0
If it says Power Management is on turn it off by doing this
open your favorite text editor with root priviledes (maybe gedit) and
open this file
Code:
/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
By Default you should see a line like this:
Code:
[connection]
wifi.powersave = 3
change the = 3 to = 2 save and reboot.
Then issue the command
Code:
iwconfig
again
and the line Power Management should say off.

See if that solves the problem.

If it does not you need to look elsewhere and you can change the setting back to 3 to turn it back on.
okay i did all that, it says off. That's really stupid that by default it does that, time will tell if it worked.
 
OP
CrazedNerd

CrazedNerd

Well-Known Member
Joined
Mar 31, 2021
Messages
833
Reaction score
333
Credits
7,108
can you plug in your wifi and run inxi -Nn and post back the result
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlp5s0 state: up mac: 20:1e:88:d5:ae:bc
Device-2: Intel Ethernet I225-V driver: igc
IF: enp6s0 state: down mac: 04:42:1a:ef:58:a6
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,167
Reaction score
2,058
Credits
23,570
I was half expecting to see a RTL wifi with the wrong driver, but what you have looks fine to me,
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Latest posts

Top