Thermal Sensors NCT6797


New Member
Hello everyone,

I only found out about Steam Play / Proton recently and am now looking to completely abolish the windows install I still have for gaming purposes only. However, I can't get my thermal sensors or PWM fans to work as intended / at all. Here's the problem:
  1. My mainboard (MSI B450-A Pro) has a NCT6797D controller for its sensors
  2. sensors-detect finds nothing, except for an unknown device at address 0xd451:
    Trying family `VIA/Winbond/Nuvoton/Fintek'...               YesFound unknown chip with ID 0xd451
  3. As Nuvoton is the correct manufacturer, I assume that this is the controller I'm looking for
  4. According to this, NCT6797D is supported by the nct6775 driver, which I have installed but not loaded into the kernel
  5. modprobe nct6775 on its own does not work. modprobe: ERROR: could not insert 'nct6775': No such device
  6. Tried forcing the IDs found here (0xd450, 0xd451). Neither worked, same error as before.
  7. Forcing 0xd120 OR 0xd352 both kind of work. sensors-detect still detects nothing, but running sensors afterwards returns something:
  8. Code:
    nct6793-isa-0a20Adapter: ISA adapter
    in0: +0.70 V (min = +0.00 V, max = +1.74 V)
    in1: +1.01 V (min = +0.00 V, max = +0.00 V) ALARM
    in2: +3.36 V (min = +0.00 V, max = +0.00 V) ALARM
    in3: +3.30 V (min = +0.00 V, max = +0.00 V) ALARM
    in4: +1.02 V (min = +0.00 V, max = +0.00 V) ALARM
    in5: +0.14 V (min = +0.00 V, max = +0.00 V) ALARM
    in6: +0.86 V (min = +0.00 V, max = +0.00 V) ALARM
    in7: +3.36 V (min = +0.00 V, max = +0.00 V) ALARM
    in8: +3.25 V (min = +0.00 V, max = +0.00 V) ALARM
    in9: +1.82 V (min = +0.00 V, max = +0.00 V) ALARM
    in10: +0.00 V (min = +0.00 V, max = +0.00 V)
    in11: +0.72 V (min = +0.00 V, max = +0.00 V) ALARM
    in12: +1.10 V (min = +0.00 V, max = +0.00 V) ALARM
    in13: +0.67 V (min = +0.00 V, max = +0.00 V) ALARM
    in14: +1.50 V (min = +0.00 V, max = +0.00 V) ALARM
    fan1: 0 RPM (min = 0 RPM)
    fan2: 906 RPM (min = 0 RPM)
    fan3: 0 RPM (min = 0 RPM)
    fan4: 619 RPM (min = 0 RPM)
    fan5: 0 RPM (min = 0 RPM)
    SYSTIN: +27.0°C (high = +80.0°C, hyst = +75.0°C) sensor = CPU diode
    CPUTIN: +30.0°C (high = +115.0°C, hyst = +90.0°C) sensor = thermistor
    AUXTIN0: +34.0°C (high = +115.0°C, hyst = +90.0°C) sensor = thermistor
    AUXTIN1: -128.0°C sensor = thermistor
    AUXTIN2: +42.0°C sensor = thermistor
    AUXTIN3: -1.0°C sensor = thermistor
    SMBUSMASTER 0: +31.5°C
    PCH_CHIP_TEMP: +0.0°C
    PCH_CPU_TEMP: +0.0°C
    intrusion0: ALARM
    intrusion1: ALARM
    beep_enable:           disabled
  9. Obviously those are still incorrect readings (-128C). Any ideas on how to proceed?
  10. General System information:
  11. Code:
    CPU: 6-Core AMD Ryzen 5 3600
    Kernel: 4.19.0-9-amd64 x86_64 bits: 64 Desktop: Cinnamon 3.8.8
      Distro: Debian GNU/Linux 10 (buster)
    Type: Desktop Mobo: Micro-Star model: B450-A PRO (MS-7B86)

Last edited:


New Member
I have what I believe to be the same I/O, though it's reporting as nct6797, but with the same measurement points as you're seeing. I'm adding on the question in hopes that someone can point me towards info that explains what each of those points are reporting on.

According to Nuvoton that Super I/O doesn't even exist (NCT6796D?). My board also uses the Nuvoton NCT7802 but I'm not sure if it's the 'Y' version or not. And again, trying to find any information about it is challenging. According to Nuvoton the 'Y' version has 3 on-chip and three remote input thermal sensors and temp1-6. Would like to know which is which, for example.


New Member
Hi, I was having a very similar problem and the solution was to add option "acpi_enforce_resources=lax" to parameter GRUB_CMDLINE_LINUX_DEFAULT= in /etc/default/grub and then run update-grub and reboot.


Super Moderator
Staff member
Gold Supporter
G'day all and welcome to, although I note the first two Members have been here a couple of months :)

Let us know what Linux Distros you are using (@c0nnect4 is using a Debian-based one or Manjaro), and if you wish I can tell you how to insert the string provided in your startup parameters, and then if it works for you, make the permanent modifications to your Grubs.

@rbt has a Windows, and will likely already have a Grub Menu.


Chris Turner

Members online