• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Tp Link wn781nd not working in linux


New Member
Jul 30, 2020
Reaction score
I bought a tp link wn781nd ver:3.20 WiFi card to give an upgrade to my old desktop computer.
I use kubuntu in this computer but the WiFi doesn't work.
When I boot up the computer the WiFi scans appears but disappears after few seconds and never comes back and I am not able to connect to the WiFi network.

I have kernel 5.4.0-42-generic. and Kubuntu-20.04

The WiFi card works fine in windows 10(dualboot)

I also tried running it in kernel 4.2.7 (because the engineer at tplink whom I have been contacting with regarding this problem said that the card only supports kernel 2.6.42 ~ 4.3) but the problem didn't get solved.

I also tried it on manjora (live) it didn't work.

What should I do?
Please help.
Last edited:

Members online

No members online now.

Latest posts