Trusted Platform Module (TPM)/ HP prodesk

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
5,757
Reaction score
3,939
Credits
42,594
well its taken me a year to figure this out,
download bash tools for tpm
enter tpm-version....... [tpm not found]
Now I know its there somewhere so scoured the net for tpm/HP, could only find instructions for windows but as its a BIOS thing , I followed them, enter bios, press F10 go to security enable tpm chip, sounds easy... no tpm chip listed,o_O
so I decided to go through every section of the bios still no tpm chip... I did see a security module [disabled] with no further information I took the chance and changed it to enable..
whoopeee it worked I now have a working TMP.:p

Moral of the story, If at first you don't succeed then walk away and come back at a later date , dont take it for read that generic instructions will match your on screen output, be willing to take a chance if you think it Right.. and for the newbie write down everything you do just in case it goes base over apex, then its easy to go back and re-instate previous configerations

Brian
 


Aren't there two version of TPM, a hardware tpm chip and the other is a software version which is programmed into the firmware of your motherboard.
 
mine is a chip on board
 
Great to see more people enabling tpm, I run it as well.

Question, are you seeing information on dmesg that the tpm is successfully in use? I assume that from your statement that it is properly working(TPM 2.0).

Have you seen any bugs, or hit any interesting logging since configured?
 

Members online


Top