Ubuntu VM won't work, but Debian & Windows do

OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
Kinda a shot in the dark, but have you tried installing the full meta package 'build-essential'?
Alright I spoke too soon.... now I'm getting this error over and over interfering with basic functioning of the VM:

VboxClient: Failure waiting for event, rc=VERR_INVALD
 


Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,761
Reaction score
1,176
Credits
13,105
Alright I spoke too soon.... now I'm getting this error over and over interfering with basic functioning of the VM:

VboxClient: Failure waiting for event, rc=VERR_INVALD
There is a ticket for corrupted extension pack on version 6.1.34 here - https://www.virtualbox.org/ticket/20916

Have a look at this file /usr/lib/udev/rules.d/60-vboxguest.rules. and post back the contents

Does it show -
KERNEL=="vboxuser", NAME="vboxuser", OWNER="root", GROUP="users", MODE="0660"

Or does it show-
KERNEL=="vboxuser", NAME="vboxuser", OWNER="root", MODE="0660", TAG+="uaccess"
 
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
There is a ticket for corrupted extension pack on version 6.1.34 here - https://www.virtualbox.org/ticket/20916

Have a look at this file /usr/lib/udev/rules.d/60-vboxguest.rules. and post back the contents

Does it show -
KERNEL=="vboxuser", NAME="vboxuser", OWNER="root", GROUP="users", MODE="0660"

Or does it show-
KERNEL=="vboxuser", NAME="vboxuser", OWNER="root", MODE="0660", TAG+="uaccess"
hey man this is a stupid question, but I'm having trouble finding the answer from search engines....

so on Mint, I can clearly see a separate "file system" folder with lib directory and other non-personal files. But Ubuntu doesn't have GUI access to this and through the find command, it's not coming up for me. How do you access this on Ubuntu?
 

SlowCoder

Gold Member
Gold Supporter
Joined
May 2, 2022
Messages
456
Reaction score
313
Credits
3,611
so on Mint, I can clearly see a separate "file system" folder with lib directory and other non-personal files. But Ubuntu doesn't have GUI access to this and through the find command, it's not coming up for me. How do you access this on Ubuntu?
Mint is basically Ubuntu with changes to the desktop, and a few other things. I don't have Ubuntu installed, but in Mint, /lib is symlinked to /usr/lib, and is world readable (writable by root). I see no reason why Mint's filesystem structure would be any different from Ubuntu.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,761
Reaction score
1,176
Credits
13,105
hey man this is a stupid question, but I'm having trouble finding the answer from search engines....

so on Mint, I can clearly see a separate "file system" folder with lib directory and other non-personal files. But Ubuntu doesn't have GUI access to this and through the find command, it's not coming up for me. How do you access this on Ubuntu?
Just navigate to the file location through the file manager and open it with your text editor, to make changes to the file you will have to be root, I believe Mint uses Nemo - the file structure is the same on Ubuntu and it uses Nautilus file manager - Here is mine through Thunar file manager which is Xfce - just click on File System then 'usr' then 'lib' then 'udev' then 'rules.d' all we are doing now is just checking the contents of the file - IF we need to edit it that command will be
Code:
sudo texteditor /usr/lib/udev/rules.d/60-vboxguest.rules
NOTE: where it says texteditor substitute that with your actual text editor - Ubuntu uses Gedit, I am not sure what Mint uses
 

Attachments

  • 2.png
    2.png
    115.1 KB · Views: 50
Last edited:
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
Just navigate to the file location through the file manager and open it with your text editor, to make changes to the file you will have to be root, I believe Mint uses Nemo - the file structure is the same on Ubuntu and it uses Nautilus file manager - Here is mine through Thunar file manager which is Xfce - just click on File System then 'usr' then 'lib' then 'udev' then 'rules.d' all we are doing now is just checking the contents of the file - IF we need to edit it that command will be
Code:
sudo texteditor /usr/lib/udev/rules.d/60-vboxguest.rules
NOTE: where it says texteditor substitute that with your actual text editor - Ubuntu uses Gedit, I am not sure what Mint uses
Okay so my understanding is there's two types of files. The "personal files" that you can save something you made like a cat picture. And the "file system" which is the folders linux makes to run the system like "lib" folder you are referring to.

On Linux Mint, it clearly lets you go to the "file system" as one of the choices on the left. Then one can right click open in terminal.

But on Ubuntu, I don't see a "file system" folder. Just the "personal files". So I can't access it via GUI or terminal.

I tried the gedit command you listed above. It ran, and opened gedit with an empty document.
 
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
In a new Debian VM, I tried to run the command you gave me to get the Vbox Additions to actually run and it gave the attached screenshot errors.
 

Attachments

  • Screenshot from 2022-05-27.png
    Screenshot from 2022-05-27.png
    59.2 KB · Views: 47

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,761
Reaction score
1,176
Credits
13,105
Okay so my understanding is there's two types of files. The "personal files" that you can save something you made like a cat picture. And the "file system" which is the folders linux makes to run the system like "lib" folder you are referring to.

On Linux Mint, it clearly lets you go to the "file system" as one of the choices on the left. Then one can right click open in terminal.

But on Ubuntu, I don't see a "file system" folder. Just the "personal files". So I can't access it via GUI or terminal.

I tried the gedit command you listed above. It ran, and opened gedit with an empty document.
I do not understand exactly what you are doing ? If Mint is your Host then just click on File System it should open the Directory Tree then just navigate to the required folder and check the above listed file - that file will only be on the Host not the VM / Ubuntu - since Oracle VirtualBox is installed on the Host which would be Mint
 
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
I do not understand exactly what you are doing ? If Mint is your Host then just click on File System it should open the Directory Tree then just navigate to the required folder and check the above listed file - that file will only be on the Host not the VM / Ubuntu - since Oracle VirtualBox is installed on the Host which would be Mint
Ohhhhh. There's no file there with that name, see the attached screen shot
 

Attachments

  • screenshot2.png
    screenshot2.png
    98.2 KB · Views: 50

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,761
Reaction score
1,176
Credits
13,105
Ohhhhh. There's no file there with that name, see the attached screen shot
Ok that is good the file is not there - now open VirtualBox Manager click on Settings then Shared Folders now click the + icon you should see the following (see Image File) click the drop down arrow select Other and navigate to the folder you want to share now put a check mark in Automount and click OK - now click Start once it has loaded you should see a folder (see Image File) providing you have the extension pack installed - it should show as a Drive in the File Manager on the Guest machine
 

Attachments

  • 6.png
    6.png
    46.8 KB · Views: 46
  • 8.png
    8.png
    30.2 KB · Views: 51
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
Ok that is good the file is not there - now open VirtualBox Manager click on Settings then Shared Folders now click the + icon you should see the following (see Image File) click the drop down arrow select Other and navigate to the folder you want to share now put a check mark in Automount and click OK - now click Start once it has loaded you should see a folder (see Image File) providing you have the extension pack installed - it should show as a Drive in the File Manager on the Guest machine
ok nice it's working now. Thanks for your time and help. I appreciate it. I'm so sorry this got so complex for a simple thing. I made a clone of the Ubuntu VM and the clone works fine now. Not sure what randomly stopped that error.

If you can please explain the Debian Command line issue above, I can run guest additions there. I was using the command you gave me
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,761
Reaction score
1,176
Credits
13,105
If you can please explain the Debian Command line issue above, I can run guest additions there. I was using the command you gave me
The root cause is that GCC is missing in the guest, which is required to build the kernel modules. One way is
reinstalling VirtualBox Guest Additions entirely (run these inside of the mounted Guest Additions ISO directory):
cd /media/*/*/
sudo ./VBoxLinuxAdditions.run - is located on the Guest machine not the Host machine it should show once inserted like an extra drive or CDROM - you need to open a terminal at that location or use the cd command to change the terminal to that directory

the next command - sudo texteditor /usr/lib/udev/rules.d/60-vboxguest.rules was to 1) check to see if it actually existed and 2) if it did exist it would most likely needed to be modified and make a custom command, but since it was not there and it is now working we did not have to make that file or modify it

and this command - sudo usermod -a -G vboxusers USERNAME - is to add the user to the Vbox User group which needs to be created when installing VirtualBox

Anyway I am glad it is now fixed
 
Last edited:
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
The root cause is that GCC is missing in the guest, which is required to build the kernel modules. One way is
reinstalling VirtualBox Guest Additions entirely (run these inside of the mounted Guest Additions ISO directory):
cd /media/*/*/
sudo ./VBoxLinuxAdditions.run - is located on the Guest machine not the Host machine it should show once inserted like an extra drive or CDROM - you need to open a terminal at that location or use the cd command to change the terminal to that directory

the next command - sudo texteditor /usr/lib/udev/rules.d/60-vboxguest.rules was to 1) check to see if it actually existed and 2) if it did exist it would most likely needed to be modified and make a custom command, but since it was not there and it is now working we did not have to make that file or modify it

and this command - sudo usermod -a -G vboxusers USERNAME - is to add the user to the Vbox User group which needs to be created when installing VirtualBox

Anyway I am glad it is now fixed
ah makes sense. thanks so much for your help

hey I'm running out of space on the harddrive and trying to move this to an external USB storage. But when I right click a virtual machine and hit "move", it doesn't show the USB, just my local machine as options/folders. have you seen this before?
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,761
Reaction score
1,176
Credits
13,105
But when I right click a virtual machine and hit "move", it doesn't show the USB, just my local machine as options/folders. have you seen this before?
Open VirtualBox and right-click on the virtual machine that needs USB access.
Next, click on Settings.
Locate USB in the VM window and click on it
The USB should appear as available.
Click on the + button located under the USB Device Filter to add a new device.
That is all, when you start the Virtual Machine it should now have access to the USB.
 
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
Open VirtualBox and right-click on the virtual machine that needs USB access.
Next, click on Settings.
Locate USB in the VM window and click on it
The USB should appear as available.
Click on the + button located under the USB Device Filter to add a new device.
That is all, when you start the Virtual Machine it should now have access to the USB.
I am sorry, I believe this is a miscommunication. Virtual Box machines have .vdi and .vbox files. I am saying I would like to move these files to a USB drive. (Moving the VM itself)

Moving a VM to a USB is different from, using a USB drive on a VM.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,761
Reaction score
1,176
Credits
13,105
I am sorry, I believe this is a miscommunication. Virtual Box machines have .vdi and .vbox files. I am saying I would like to move these files to a USB drive. (Moving the VM itself)

Moving a VM to a USB is different from, using a USB drive on a VM.
I believe you can just copy the VirtualBox VMs folder under your Home directory to a USB then import it to your VM VirtualBox
 
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
I believe you can just copy the VirtualBox VMs folder under your Home directory to a USB then import it to your VM VirtualBox
I tried that but it when I try to pick the new vdi location, it only shows me files on the PC. USB drives aren't even choices
 
OP
NucleusChemistry
Joined
Apr 21, 2022
Messages
33
Reaction score
3
Credits
269
Have a look here -
Yes that video is super useful, but note in his video there's a third column to the left of the interface that allows for USB drive selection. While as in the screen shot I attached here, there's no 3rd column or drives to select.
 

Attachments

  • Screenshot from 2022-05-31.png
    Screenshot from 2022-05-31.png
    31.4 KB · Views: 34
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top