Unable to detect wifi hardware on an owasys embbeded system running Debian 9

overpriced

New Member
Credits
0
Initially after SSHing into the microcontroller I was able to get the wifi on with this line.

Code:
ip link set mlan0 up
Subsequent running of iwconfig would display mlan0 in the list of the devices.

Next day after the microcontroller has been switched of for the night I am unable to replicate that set up.

Output of runnng lsmod:

Module Size Used by
musb_dsps 20480 0
musb_hdrc 98304 1 musb_dsps
udc_core 28672 1 musb_hdrc
usbcore 204800 1 musb_hdrc
phy_am335x 16384 2
phy_am335x_control 16384 1 phy_am335x
phy_generic 16384 1 phy_am335x
usb_common 16384 5 phy_am335x,udc_core,musb_hdrc,musb_dsps,usbcore
c_can_platform 16384 0
c_can 20480 1 c_can_platform
mcp251x 20480 0
snd_soc_tlv320aic31xx 36864 1
can_dev 24576 2 mcp251x,c_can
musb_am335x 16384 0
omap_wdt 16384 0
sd8xxx 552960 0
mlan 430080 1 sd8xxx
cfg80211 266240 1 sd8xxx
ppp_generic 36864 0
slhc 16384 1 ppp_generic
owa4x_gpio 16384 0
ip_tables 24576 0
x_tables 32768 1 ip_tables


output of running iwconfig -a does not list mlan0, which it did first time around:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.8.244 netmask 255.255.255.0 broadcast 192.168.8.255
inet6 fe80::eb2:b7ff:fed8:9bd6 prefixlen 64 scopeid 0x20<link>
inet6 fdf4:7177:49ee:0:eb2:b7ff:fed8:9bd6 prefixlen 64 scopeid 0x0<global>
ether 0c:b2:b7:d8:9b:d6 txqueuelen 1000 (Ethernet)
RX packets 456 bytes 40141 (39.2 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 346 bytes 59107 (57.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 51

eth0:0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.10.1 netmask 255.255.255.0 broadcast 0.0.0.0
ether 0c:b2:b7:d8:9b:d6 txqueuelen 1000 (Ethernet)
device interrupt 51

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


this is what I get if I run dmesg:

[ 5.939860] mlan: loading out-of-tree module taints kernel.
[ 6.398869] systemd-journald[107]: Received request to flush runtime journal from PID 1
[ 6.418469] wlan: Loading MWLAN driver
[ 6.480709] wlan: Driver loaded successfully


I suspect `loading out-of-tree module taints kernel` may be an issue but I do not know how to proceed further.
In all other logs there is no mention of anything relating to wlan/mlan.

I have tried unloading the modules in question and restarting the whole networking:

Code:
sudo rmmod sd8xxx
sudo rmmod mlan
modprobe sd8xx
modprobe man
/etc/init.d/networking restart

This still has not fixed the problem.

Besides refreshing the whole system and hoping it works just like the first time I do not really know how to proceed with trying to fix this issue or even what further debugging to undertake.


Thanks for your help.
 
Last edited:


inigoalday

New Member
Credits
0
Most probably you need to switch on the WiFi module on the owasys unit, as by default it is switched off. You can do this with this command:

# Start_BT_WiFi 1

Bash:
[email protected]:~# Start_BT_WiFi 1
Enter Start_BT_WiFi version(CYA 100_9011 V1.0.0) program
[1]+  Done                    dmesg
[email protected]:~# dmesg
[78768.142896] mmc1: new high speed SDIO card at address 0001
[78768.150461] vendor=0x02DF device=0x9135 class=0 function=1
[78768.150594] SDIO: max_segs=64 max_seg_size=33553920
[78768.150603] rx_work=0 cpu_num=1
[78768.151480] wlan: Enable TX SG mode
[78768.151490] wlan: Enable RX SG mode
[78768.185138] Request firmware: mrvl/sd8887_uapsta_a2.bin
[78768.918255] Wlan: FW download over, firmwarelen=616840 downloaded 616840
[78769.430861] WLAN FW is active
[78769.494946] fw_cap_info=0x187bff03, dev_cap_mask=0xffffffff
[78769.495107] HDW Enable CCA ED
[78769.504985] SDIO rx aggr: 1 block_size=412
[78769.505003] wlan: Enable RX SG mode
[78769.505009] mpa_rx_buf_size=65280
[78769.624974] CMD_RESP: cmd 0x23a error, result=0x2
[78774.465220] creating custom regulatory domain failed
[78774.636825] get_channel when STA is not connected
[78774.673109] get_channel when AP is not started
[78774.695268] wlan: version = SD8887-15.68.7.p189-C4X15C605-GPL-(FP68)
[78774.716780] BT FW is active(0)
[78774.716797] BT: FW already downloaded!
[email protected]:~# iwconfig
lo        no wireless extensions.

can3      no wireless extensions.

can1      no wireless extensions.

eth0      no wireless extensions.

mlan0     IEEE 802.11-DS  ESSID:"" 
          Mode:Managed  Access Point: Not-Associated   Bit Rate:1 Mb/s   
          Tx-Power=18 dBm   
          Retry limit:9   RTS thr=2347 B   Fragment thr=2346 B   
          Encryption key:off
          Power Management:on
          Link Quality=0/5  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

can4      no wireless extensions.

sit0      no wireless extensions.

can2      no wireless extensions.

uap0      IEEE 802.11-DS  ESSID:"" 
          Mode:Master  Frequency:2.437 GHz  Access Point: Not-Associated   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[email protected]:~# iwlist mlan0 scan
mlan0     Scan completed :
          Cell 01 - Address: 00:1F:CA:60:66:A0
                    ESSID:"asdf"
                    Mode:Master
                    Frequency=2.412 GHz (Channel 1)
                    Quality:1/5  Signal level:-83 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:Beacon interval=100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD06004096010100
                    IE: Unknown: DD050040960304
                    IE: Unknown: DD050040960B01
                    IE: Unknown: DD180050F2020101810003A4000027A4000042435E0060
                    Extra:band=bg
          Cell 02 - Address: E6:A5:BE:5E:9A:8E
                    ESSID:"asdf" [2]
                    Mode:Ad-Hoc
                    Frequency=2.432 GHz (Channel 5)
                    Quality:2/5  Signal level:-70 dBm  Noise level:-96 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra:Beacon interval=100
                    IE: Unknown: DD09001018020010000000
                    Extra:band=bg
          Cell 03 - Address: 78:C4:0E:81:69:F0
                    ESSID:"asdf" [3]
                    Mode:Master
                    Frequency=2.437 GHz (Channel 6)
                    Quality:3/5  Signal level:-62 dBm
 


Members online


Latest posts

Top