Unable to install or load from ASRock Z97 motherboard

Michael0105

New Member
Hello there. I just got an extra SSD installed on my system that I planned on loading Ubuntu on (or other linux distro). I downloaded Ubuntu OS 19.10 and also 18.04 and installed it on a USB via Rufus and also Unetbootin. Plus also tried a bootable DVD. I even tried getting elementary os, mint, and other options but have the same issue with ALL methods.

I boot from the USB drive and get to the screen where I can try the system or install it. After I make any of the selections, I hear my PC start to roar up then it powers down and restarts it. I can not get past this step. It happens when I try to install and also when I try the system. Currently my main SSD is running Windows 10 x64. Any ideas to get me past this issue??? Been looking for hours for help....

Seen info about disabling secure boot (already disabled) and disabling UEFI (Pretty sure that is done as well). I dug through my BIOS and tried everything I can. I got my mobo a few months ago and not 100% familiar with it. I remember my old MSI mobo had that option clear as day. I searched through the ASRock manual for quite some time and couldnt find anything.

ASRock Z97 Anniversary
Intel i5 4th gen
32 GB DDR3
Gigabyte GTX960
PNY 250Gb SSD (Windows 10)+128Gb SSD (New)
2TB Seagate HDD (Storage)
Dual BENQ 24" Gaming monitors
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
You've been waiting patiently for 2 days and I don't have any easy-peasy solution for you.

G'day and welcome to linux.org :)

... and you've already tried a few of the things I would have suggested.

I would ask if you had verified the downloads but with a spread of distros such as you describe, that is unlikely to be an issue.

...and also when I try the system.
Does that mean choosing not to open the installer, and just trying to use the Live environment?

Cheers

Chris Turner
wizardfromoz
 

Alexzee

Active Member
When you went into the BIOS did you go into the boot menu and make the CDROM drive the first choice in order to boot the CD? And the same with the usb flash drive?

Does your mobo have say F8 to be able to choose a boot device?

Did you shrink your Windows partition to make room for your Linux installation?

Another idea :cool:
Try giving Asrock a call, explain the situation to them and see what they have to say.

With some mobo's you might have to install in UEFI mode. (If that's what's going on.)
 
Last edited:

Alexzee

Active Member
How old is your mobo?
 



Members online


Latest posts


Top