Unable to print wirelessly

Richard Wallace

New Member
Joined
Nov 5, 2021
Messages
25
Reaction score
9
Credits
225
I just switched ISP from CenturyLink to Quantum and now I can't print wirelessly as I did with CenturyLink. I am able to print wired. I get the message lpr: Error - No default destination. I'm running Mint 21.3 and the printer is a Brother HL-L2350DW. No printer is visible to set as default. The light indicating a wifi connection is on, not blinking, so it appears the printer is connected to the wifi. I called Brother printer support and they told me they don't provide support when you're running Linux. Can anyone help with this? I'd be much obliged.
 


With my HP printer, I had to go into my ISP provided router settings and determine the IP address of the printer. Then use that address on my Mint machine to search for a network printer. It's been a while since I did it. But that's the basics for what I did. Hope it helps
 
It's most likely the IP address of the printer has changed with the new router and server. If it's set up to an New IP you will have to change that address in the Mint Printer app.
 
Last edited:
Have you tried [in the print manager,] uninstalling the current printer, then let it search and re-install the drivers. in theory, it should find the printer's new ID
 
I would suggest running netdiscover to find all hosts on the local subnet. Only a rooted device is likely to block an ARP ping request, unlike an ICMP echo request. nmap can help too. Use nmap to scan your local subnet for active hosts on your wifi network. Use the /usr/sbin/ip command and say ip a to find the IP addresses of your network devices on your Linux computer and the associated netmask. A netmask of 255.255.255.0 is the same as /24. If your IPv4 address for your computer was say 192.168.0.10 and your netmask was showing 255.255.255.0 then you would use nmap to scan your subnet like this: nmap -sn -PR 192.168.0.0/24 and then redirect your output to a file for easy viewing. You could use netdiscover -i interfacename 192.168.0.0/24 using the name of the interface from the output of ip a for interfacename. You will need to run these commands as root. Hint: You can rename the names of your network devices in /etc/network/interfaces if you are using the ifupdown package for network management. Then you won't have to remember those weird looking names anymore. You can rename them to things like eth0 or wlan0. See the man page for interfaces(5) for more on that. Use apt install netdiscover nmap nmap-common as root to get the netdiscover and nmap packages. apt is used by Debian type Linux distributions. Others use a package manager that uses a different name so consult your documentation for that.

Signed,

Matthew Campbell
 
I have a Printer that's both...I use the USB cable...much easier.
1717803551608.gif
 
Thanks for the replies. It turns out the installer didn't install the correct equipment according to Quantum tech support. They're due to come back out and install the correct equipment next Tuesday. If I still can't get the printer to print I'll try the suggestions. The tech said the installer would make sure all my devices can connect though so I'll be a happy camper if everything works out.
 
The problem is common and once your printer IP address changes for any reason you lose wireless print. So best is to look at what IP address you had on your printer in the computer's configuration for the printer. Then check the IP address you have on your computer in the network settings... You should see something like 192.168.1.xx on your computer. It may be different but important to check the first 3 sets of numbers on your network setting. Then note the address. Go to the printer and hard set a static IP address using what you found on the computer so xxx.xxx.xxx.2 and change the IP for the printer configuration on your computer to match it. You should be done then.
 
With arp -a the printer doesn't show up. The printer itself reports an IP address of 192.168.0.6. I am able to ping that address. What does this mean?
 
Thanks for the replies. It turns out the installer didn't install the correct equipment according to Quantum tech support. They're due to come back out and install the correct equipment next Tuesday. If I still can't get the printer to print I'll try the suggestions. The tech said the installer would make sure all my devices can connect though so I'll be a happy camper if everything works out.
do yourself a huge favor and have the tech set the printer with a static IP address. This will save you problems later on.
 
I set the printer to static IP, no change. Rebooted computer. Still no printer detected. An installer came out today to make equipment changes I was told I would need. Turns out all he was going to do is add repeaters to extend the range of the Wifi which isn't going to help. I'll go back over the suggestions I've been given here and see if implementing them helps. I am able to print if I hook up wired at least. But Mint has always worked flawlessly in detecting the printer. I'm baffled why I need to take extra measures.
 
I set the printer to static IP, no change. Rebooted computer. Still no printer detected. An installer came out today to make equipment changes I was told I would need. Turns out all he was going to do is add repeaters to extend the range of the Wifi which isn't going to help. I'll go back over the suggestions I've been given here and see if implementing them helps. I am able to print if I hook up wired at least. But Mint has always worked flawlessly in detecting the printer. I'm baffled why I need to take extra measures.
you have to set the printer to a static IP that is on the same segment. if you are 192.168.1.15 the printer would be 192.168.1.2 , If you were at 10.10.10.135 the printer can be 10.10.10.2, and you have to join the printer to the wifi including the password. Just setting static IP will do nothing without the rest. Once you do that you should be able to easily go on and never have a problem again unless you change routers. I do not think this is an OS problem the issue is you changed wifi networks and now you have to set it back up, this would be true with any OS or network.
 
I've tried a different route. Even though Mint always had the driver before when I was able to print wirelessly I downloaded and installed the drivers for my printer. The light indicating the printer is connected to the network is on as I mentioned before. Since downloading the drivers I tried to print again and this time I get this in the terminal: HLL2350DW is ready and printing - but it still doesn't print. I tried restarting the printer and rebooting the computer but nothing changed. The printer is showing up in Printers and I set it as default.
 
@Richard Wallace - this may be of assistance to you.

I ran a search on

linux mint Brother HL-L2350DW

and took a look at the first one on the list, from 2022

Brother HL-L2350DW does not like Linux Mint 21 [SOLVED...]

... which is worth persevering through the whole 2 pages to see what didn't work.

At the bottom of page 2 is the solution.

If you would rather fast-track, the link the OP refers to is

https://easylinuxtipsproject.blogspot.com/p/brother-printers.html

You may want to take a Timeshift snapshot first if all but the printer is working, and then if you succeed with the above, delete the snapshot and replace it with a new one.

HTH and Good Luck

Chris Turner
wizardfromoz
 
Huh. I didn't try searching on just linux mint HL-L2350DW. I see the results of that search now. It makes sense. I've been running Mint for years and never had a problem with printers until loading Mint 21.3. I'll look into implementing what was suggested. Another problem has cropped up. I can print with a USB cable hooked up but it takes several minutes for printing to begin. I recently loaded Mint 21.3 on both of my computers and both have the same problems. Thanks for looking into this.
 
Rather than take all the steps recommended I thought I'd try going back to an earlier release of Mint. I tried 20.3 and 21 but I still couldn't print. There may be a conflict between this particular Brother printer and Mint 21.3 but I still think there's a problem caused by the change in ISP. If I ever find a solution I'll definitely pass it along.
 
Let me know if I should start a new thread. I thought since there's already some background established on this thread I would continue with printer problem inquiries. I've got a real puzzler.
With no action on my part, printing begins as soon as I submit a print job. That's on one computer. I have another older Dell laptop where printing is not working at all. On the computer where printing is working I didn't have to obtain a driver, Mint detects the printer as soon as it's connected. On the computer that does not print the printer goes undetected. There's very little difference between the two computers as far as hardware, and they are both running Mint 21.3. I haven't made any changes to print settings on either computer. But one detects the printer and the other does not.
 
I forgot to mention in my last post that with both machines the printer is connected with a USB cable. Wireless printing does not work on either machine.
 
Found a solution for both wired and wireless printing. You have to go to Printers/Add Printer/LDP/LPR Host/Enter the IP address for the printer, no Queue entry needed, choose correct driver from list/Apply. It took me days and dozens of searches to find this solution. Hopefully this will help someone avoid all the trouble I went through
 
Found a solution for both wired and wireless printing. You have to go to Printers/Add Printer/LDP/LPR Host/Enter the IP address for the printer, no Queue entry needed, choose correct driver from list/Apply. It took me days and dozens of searches to find this solution. Hopefully this will help someone avoid all the trouble I went through
no, actually the information was given to you days ago, you just didn't notice it.
 


Latest posts

Top