Unsupported PDF data for Direct Print :1000


New Member
Oct 16, 2019
Reaction score
While printing a PDF (CUPS printing in Linux server using command lpr -P <filename>) i get a paper printed with the following data : "Unsupported PDF data for Direct Print :1000". When tried in Windows, it got printed without any issues. Could anyone please help in finding a solution for this ?

What kind of printer is it? Different printers have different error codes. Make? Model?

How was the PDF made?

Is a USB stick involved here?

There's this:
Error Code 1031 - 1033

CauseRecommended solution
  • The PDF file includes an unsupported data format.
  1. Save the file using the "Print to file" feature of the Brother printer driver, to a USB flash drive using a PC. (To see how to use the "Print to file" feature, click here.) Then, print the document from the USB flash drive.

  2. Print the document directly from a computer.
Source - https://support.brother.com/g/b/faqend.aspx?c=us&lang=en&prod=hl4040cn_all&faqid=faq00002422_000

Its Brother printer. (HL-L6400DW). PDF are made using jasper report tool. Actually the print is initiated from Redhat linux server via CUPS using lpr command (lpr -P <Printer Name> <file name>)
I had the same issue with my Brother L3770, and followed ARochester's advice above.

1. Print to file (in my case, option 'Microsoft print to PDF') to a memory stick
2. Placed stick in the printer and printed.

Worked like a charm! Thank you.