Upgraded Olivia to Petra, now black screen, no launch



Boy oh boy...I think I stepped in a pile of it this time. My Linux Mint Olivia 15 was working just fine. Was that good enough for me? No. I HAD to get Linux 16 Petra. I followed the Apt-get terminal commands. Now my computer starts like it is going to launch Mint with the little green "L" in the screen center...then it goes to all black screen. That's it; it just sets there. I have attempted numerous times the restore in safe mode by holding the shift key after the BIOS boot...and I have clicked all the possibilities including fixing broken program packages. Still nothing.

Is there any way I can REVERSE adding Petra and restore to my previous Olivia? My computer is booting only to LINUX (I removed Windows a while back).

By the way, I am writing this on a lightning fast Dell desktop 700 MHZ system. So I can't do too much with screen captures on my DOA Linux computer I am afraid.

Hope there's someone out there who can help.

Try interrupting your GRUB boot and insert the command "nomodeset" (without the quotes). This has helped me on Ubuntu/Mint black screen issues in the past... hope it helps you too. If it works, you can add it to your permanent GRUB boot options and keep Petra.
To clarify -- booting Olivia,

I hold the left-hand Shift key down at first splash screen where there are notices to hit F-keys to get into the BIOS.

GRUB pops up with choices. Stay on first one and hit the "E" key for edit.
Up pops the textual boot commands of GRUB.

I use down-arrow to go down thirteen lines to the stanza beginning with "linux . . ."
Hit "End" to go to end-of-line of this kernel line, hit spacebar once and type in "nomodeset," as atanere noted.

Hit F-10 to boot with your edit intact.
Thanks Pane-Free and Atanere for the nomodeset suggestion. I tried it both ways. Now I get a new black screen (only this one has text that reads "Linux Mint 16". I see a tiny flash of red by the screen edge in the upper left hand corner, then the computer goes to a full black screen with the mouse cursor flashing. It sets that way for as long as I let it.

Any other ideas? I was cautiously optimistic when I noticed some changes by adding nomodeset to the GRUB kernel but it appears I am still Petra-less.
the computer goes to a full black screen with the mouse cursor flashing
That suggests a graphics problem. Have you got a graphics card installed e.g. nVidia or ATI?

If so, you may need to install the graphics driver again.

There is a small script which I have used in the past which has helped do this automagically: https://code.google.com/p/sgfxi/

sgfxi is a self-updating nvidia, ati/amd fglrx, and xorg free driver installer and xorg configuration script written for originally for Debian, but since expanded to also include support for Ubuntu and Arch Linux systems.

..also http://smxi.org/site/install.htm ...scroll down to
Installing sgfxi (non-smxi install)

From where you are press Alt+Ctrl+1... to drop X
Log in (username and password)
To get it do: cd /usr/local/bin && sudo wget -Nc smxi.org/sgfxi && sudo chmod +x sgfxi && sgfxi
I don't think it works with sudo so : sudo su
Input: sgfxi
Follow instructions
This is a very frustrating experience. Not only has LINUX rendered my laptop useless I cannot even respond to the good people who have weighed-in with help because I am too "new" to this forum and cannot post anything that is a link. So Arochester...I really appreciate your suggestions but due to LINUX's policy I cannot address the problems I am having with anything you suggested that looks like a link to the forum.

Bottom line: I tried it all and no luck. From the root command I was advised that the linkj you suggested is "invalid."
The Google link takes me to a page that says it only works with "Linux Arch". (I tried to reference it by spelling it out and got my garter snapped with a pop up from Linux advising me that I was trying to "sneak in" a URL.

I could very well have a graphics driver problem but don't know how I can remedy it because my Linux computer is DOA so I cannot download anything. If I download it on another computer maybe I can somehow input it into the Linux machine.

Geezy Louisee I wish I'd never heard of Linux Petra.
The reason this forum does not allow you to post links is because spammers would then be able to post links as soon as they sign up. After new users are here for a while they can post links.

Now, there are some things you are leaving out.
1. can we please have the laptop specifications? Make, model, changes?
2. are you able to login to a non-graphical session?
3. If you are able to login to a non-graphical session, can you ping google?
I can remedy it because my Linux computer is DOA so I cannot download anything
You probably can download. Pressing Alt+Ctrl+1 should shut down the GUI and leave you with a text based front-end. Then the wget command should download the bit you want.
You probably can download. Pressing Alt+Ctrl+1 should shut down the GUI and leave you with a text based front-end. Then the wget command should download the bit you want.
Do you mean CTRL+ALT+F1 ?
1) An alternative to the ALT-CTRL+F1 thing is, at the Boot screen, to boot into Rescue mode whichwill start in text mode only.

2) Another alternative altogether is to boot a LiveCD, copy your Home folder to an external Hard Drive, if you have one, and do a new install - then reinstall your Home.
I downloaded and burned a DVD on another computer with the Linux Petra OS. WhenI start up my Linux laptop (HP Compaq nc6220) I get the usual grey welcome screen with the Linux 16 logo and the 3 stock desktop icons. I am guessing my graphics/video card must be OK if I can see this, maybe?
If I CTRL-ALT-F1 I can see that some of my file folders that I had when I had Olivia installed are still there. How can I copy those to another medium because it is starting to be real appealing to me to "deep-six" this Petra install and do a fresh one from the CD.

Is there any way I can launch Petra from the root command? I get the small green "L" but then the screen goes blank and I see a brief flash of red behind the blacl screen along its edge. It almost acts like it wants to load.
Well, I think I am getting closer to resolving this thing.
Earlier today I observed in one of my many fat-finger excursions that LINUX PETRA 16 was clearly enunciated on my computer. HOWEVER tonight I see my GRUB loader offers OLIVIA 15 and OLIVIA 15 RESCUE. H-m-m-m. Methinks I got a botched install job when I loaded the PETRA software. I am just about all-Petra'd-out so I booted from my OLVIA CD and can get into my HOME directory. There are several files I want to put on a flash drive however the LIVE CD apparently won't allow me to copy to or send to the flash drive any of these files because I do not have "permission.: I tried "opening as administrator" but there is no COPY option in the pop up window and if I try to hold the button down and drag and drop the file into my flash drive I get scolded for trying to move an "unmovable" file. Anyone have any tips on how I can get these files over to a flash drive while booted off the LIVE CD? Once I've done that it's just a matter of reinstalling OLVIA and then loading my profile file and a few other files I want to have. Thanks for any help.
Try adding forcevesa to the kernel line either alone or in front of nomodset and see what happens.

EDIT: must have been typing while you were posting. When reinstalling, you may want to consider using vesa if graphics continues to be a problem. In fact, you may want to configure it on install with vesa and fix the driver problem, if any, later, as I don't know how Olivia 32-bit worked for you, previously.

Best wishes, anyway!
Last edited:
Thanks for the suggestion Pane Free. I tried it both ways ("nomodset" as well as "nomodeset") because I see both syntax in this thread) but still no luck. I tried "forceversa" before and after "nomodset/nomodeset" without any change.

When I hold the shift key during the bootup I see the name of my computer followed by "Petra 16." However my GNU GRUD box shows the following:
GNU GRUB version 2.00-13ubuntu3
Linux Mint 15 MATE 32-bit, 3.8.0-19-generic (/dev/sda1)
Linux Mint 15 MATE 32-bit, 3.8.0-19-generic (/dev/sda1) -- recovery mode
Memory test (memtest86+)
Memory test (memtest86+, serial console 115200)

THEN...if I click "e" for edit on the first Linux Mate 15 entry, here is what is displayed:
getparams 'Linux Mint 15 MATE 32-bit, 3.8.0-19-generic (/dev/sda1)'

gfxmode $linux_gfx_mode
insmod gzip
insmod part_msdos
insmod ext2
set root='hd0,msdos1'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci\0,msdos1 882c39e9-e75d-4c8b-b33e-9eb856f3e0ef
search --no-floppy --fs-uuid --set=root 882c39e9-e75d-4c8b-b33e-9eb856f3e0ef
linux /boot/vmlinuz-3.8.0-19-generic root=UUID=882c39e9-e75d-4c8b-b33e-9eb856f3e0ef ro quiet splash\
initrd /boot/initrd,img-3.8.0-19-generic

Phew! I tried to type it exactly as it was justified and spaced. I hope someone can decipher this because I sure cannot.

Aside from this...does anyone know how I can copy files from my HOME file when I boot up on the CD LIVE disk? The files are visible inside the folders but the folders have an "X" on them and I cannot move or cut and paste them into a flash drive. If there is a work-around I could just save the files and reinstall from the CD LIVE disk as I am fearful if I do try to reinstall my old Linux Olivia it will delete the folders that have my profiles and documents in them.

Thanks to all for help. What a weekend.
I had the same problem when upgrading via apt upgrade rather than doing a cd full install. Petra works fine on my laptop now.
You didnt say whether or not ctrl+alt+f1 worked for you. If it does you can mount your usb drive and copy, move your files from there.
From terminal type mount. Toward the bottom you should see your usb stick. Mine is /dev/sdc1 followed by /media/username/usbstick or whatever its named. Type sudo mount /dev/sdc1 change if yours is different.
Now you can transfer your files to the usb. To transfer a whole directory like /home/username (sudo mv -rf /home/username_here /mnt. Now if you cd /mnt you should see your directory and files there. Lastly unmount with sudo umount /dev/sdc1
Thank you Boatguy. I appreciate the help. Unfortunately I tried all the variations I could think of to exacerbate typos (i.e. "nomodeset" versus "nomodset") and never saw my flash drive. I did, however come up with a work-around that enabled me to copy my files onto the stick. I booted my computer with my Olivia CD Live and then went to the FILE SYSTEM and ground down until I saw the files I wanted. I then opened them with the pop up window "Open as Administrator" then I selected "COPY"---however there was no way to paste except ON THE POP UP WINDOW. I selected my flash drive, selected "PASTE" and the files were written to the flash stick. I have just re-installed Olivia (yeah, I'm a little bruised from wasting a weekend with Petra) and now I can get back to some fun things. Thanks for you help.
Glad you got it sorted out. I have completely gave up on doing upgrades through apt for this reason. With the amount of times things have gone wrong for me, its easier just to copy my home folder and do a fresh install from cd or flash drive.
Upshot: don't try upgrading one version to the next highest, just reinstall (and keep the /home if you want). Best wishes to both of you!
Kinda why I prefer rolling release distros, it does all the work for you, and nothing gets messed up (usually).

Members online