Virtual Box Install Problem

70 Tango Charlie

Well-Known Member
Credits
161
Hi everyone,
I have been trying to install Virtual Box 6.1 on Linux Mint 19.3.
While the download went fine, when I went to install it I got the error message about 'dependency not satisfiable', shown in screen shot.
Missing Dependency VB.png

I have tried installing the libc6 but must be doing something wrong as per this screenie.
Screenshot_2020-04-04_16-16-42.png


I do not know much about programming yet, so am at a loss to know what to do next.
Thanks.
Old Geezer TC
 


smooth_buddha

Active Member
Credits
0
Hi everyone,
I have been trying to install Virtual Box 6.1 on Linux Mint 19.3.
While the download went fine, when I went to install it I got the error message about 'dependency not satisfiable', shown in screen shot.
View attachment 5936
I have tried installing the libc6 but must be doing something wrong as per this screenie.
View attachment 5937

I do not know much about programming yet, so am at a loss to know what to do next.
Thanks.
Old Geezer TC
I have exactly the same problem my friend! so far all ive been able to do is use virtual box 5.2 as we was chatting about the other day. Hopefully we will figure it out somewhow!

In the GUI software manager it only has options to install virtualbox 5.2, it doesnt seem like mint supports the latest version but that been said maube it is posible to satisfy the dependencie somewhow. im going to have a look at that dependency now
 

smooth_buddha

Active Member
Credits
0
Hi everyone,
I have been trying to install Virtual Box 6.1 on Linux Mint 19.3.
While the download went fine, when I went to install it I got the error message about 'dependency not satisfiable', shown in screen shot.
View attachment 5936
I have tried installing the libc6 but must be doing something wrong as per this screenie.
View attachment 5937

I do not know much about programming yet, so am at a loss to know what to do next.
Thanks.
Old Geezer TC

which option did you install from the virtual box site out of the list in the below picture???? As i noticed there isnt a direct link for mint version but i assume ubuntu or debian should work??

virtualbox_download_options.png
 

smooth_buddha

Active Member
Credits
0
Hi everyone,
I have been trying to install Virtual Box 6.1 on Linux Mint 19.3.
While the download went fine, when I went to install it I got the error message about 'dependency not satisfiable', shown in screen shot.
View attachment 5936
I have tried installing the libc6 but must be doing something wrong as per this screenie.
View attachment 5937

I do not know much about programming yet, so am at a loss to know what to do next.
Thanks.
Old Geezer TC
Well i currently have virtual box 5.2 installed but when running the install package for virtualbox 6.1 it seems to conflict. I dont want to uninstall current virtual box because i have some precious machines in it lol! i downlaoded the ubuntu 19.10 version for my mint machine

virtualbox_install_attempt.png
 

70 Tango Charlie

Well-Known Member
Credits
161

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
972
charlie - do not install unless you have a full on-demand snapshot via timeshift.

i'll be back with more soon

chris
 

70 Tango Charlie

Well-Known Member
Credits
161
charlie - do not install unless you have a full on-demand snapshot via timeshift.

i'll be back with more soon

chris
Thanks Wiz.
I'll wait - more patiently than ever before. LOL
OGTC
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
972
back now, typing up next post
 

70 Tango Charlie

Well-Known Member
Credits
161
back now, typing up next post
Wiz,
Just took a full snapshot in Timeshift. I now have 13 full snapshots going back as far as Jan 16, 2020.
Go at whatever speed you are comfortable with. No rush. Not going to do anything until I hear from you.
TC
 

Tolkem

Active Member
Credits
460
@70 Tango Charlie First, there are a two typos on the command you used; remove the (>=2.28) this is apt telling you that the libc6 version should be equal or higher that version 2.28 and it's not needed, also, you missed apt or apt-get, unless that's an alias it should be like this
Code:
sudo apt-get install libc6
however, I advice you to use the one Mint supports, there aren't any real mayor advantages from using a different version unless you're entirely sure otherwise, stick to the software available from the repos or use something like bullseye or a rolling distro which offers the latest packages available.

Hey Smoothie,
I tried the Debian 10.
OGTC
Pick the one for Ubuntu 18.04 since Mint 19.3 is based on it.
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
972
a handy one to remember - following do not need sudo - is

Code:
apt-cache policy
just add the package name, so, this in two of my stable

Code:
[email protected]:~$ apt-cache policy libc6
libc6:
  Installed: 2.27-3ubuntu1
  Candidate: 2.27-3ubuntu1
  Version table:
*** 2.27-3ubuntu1 500
        500 http://mirror.aarnet.edu.au/pub/ubuntu/archive bionic/main amd64 Packages
        100 /var/lib/dpkg/status
applies to you, charlie, and to buddha

Code:
[email protected]:~$ apt-cache policy libc6
libc6:
  Installed: 2.30-0ubuntu2.1
  Candidate: 2.30-0ubuntu2.1
  Version table:
*** 2.30-0ubuntu2.1 500
        500 http://archive.ubuntu.nautile.nc/ubuntu eoan-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.30-0ubuntu2 500
        500 http://archive.ubuntu.nautile.nc/ubuntu eoan/main amd64 Packages
... so buddha's ubuntu 19.10 can take the v6 of virtualbox, and charlie's can't.

if there was an update outstanding, you would see it in the difference between "installed:" and "candidate:"

of course we can go to a website such as pkgs.org and get a newer package, but unless you know what you are doing and do your homework, you may take a journey across the River Styx and enter

... drumroll

DEPENDENCY HELL

there are various ways of determining what depends on what, but one i like that is in our repos is

apt-rdepends

Code:
sudo apt-get -y install apt-rdepends
once installed, i can type, enter and get the following from charlie's mint, similarly with buddha's ubuntu

Code:
[email protected]:~$ apt-rdepends libc6
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libc6
  Depends: libgcc1
libgcc1
  Depends: gcc-8-base (= 8.4.0-1ubuntu1~18.04)
  Depends: libc6 (>= 2.14)
gcc-8-base
... so libc6 needs to have libgcc1 installed, which in turn relies on gcc-8-base, AND a version of libc6 greater than or equal to v2.14

and libc6 also depends on having that gcc-8-base too

confused?

good :p - this is just dipping your toes into dependency hell.

the apt-rdepends command acted recursively in the above case.

we can turn that around with the following, and get it to tell us what depends on libc6.

type and enter the following and then hold on to your hat

Code:
apt-rdepends -r libc6
gone goggle-eyed?

i knew in advance that there would be a lot of output, so i entered

Code:
apt-rdepends -r libc6 > depends-on-libc6.txt
which generates a text file of that name.

going to my Nemo file manager, i open the file, which is a whopping 12.4 MB, and has

265,317 lines in it.

so libc6 has 265,000+ packages depending on it - i seriously would not muck with it, hence i have to disagree with my Green Hornet friend.

more to follow after coffee :)
 

70 Tango Charlie

Well-Known Member
Credits
161
Thanks Wiz and Tolkem and Old Smoothie,
I think that VB will come to me somewhere down my education road. For now, there are too many bumps and turns.
I'll just stick to putting distros on my hdd as I have been doing. Have about 14 right now.
I will try to digest what you have written in your last post #11. {Wow, there's a lot there!!!}
Old Geezer
TC
And thanks for warning this old f--t before I got in too deep.
 

Tolkem

Active Member
Credits
460
so libc6 has 265,000+ packages depending on it - i seriously would not muck with it, hence i have to disagree with my Green Hornet friend.
Oh, I know it pulls a lot of stuff, I was simply showing how to install it and in fact told him not to but to stick with VBox 5 which works just fine and doesn't need libc6. :)
 

70 Tango Charlie

Well-Known Member
Credits
161
a handy one to remember - following do not need sudo - is

Code:
apt-cache policy
just add the package name, so, this in two of my stable

Code:
[email protected]:~$ apt-cache policy libc6
libc6:
  Installed: 2.27-3ubuntu1
  Candidate: 2.27-3ubuntu1
  Version table:
*** 2.27-3ubuntu1 500
        500 http://mirror.aarnet.edu.au/pub/ubuntu/archive bionic/main amd64 Packages
        100 /var/lib/dpkg/status
applies to you, charlie, and to buddha

Code:
[email protected]:~$ apt-cache policy libc6
libc6:
  Installed: 2.30-0ubuntu2.1
  Candidate: 2.30-0ubuntu2.1
  Version table:
*** 2.30-0ubuntu2.1 500
        500 http://archive.ubuntu.nautile.nc/ubuntu eoan-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.30-0ubuntu2 500
        500 http://archive.ubuntu.nautile.nc/ubuntu eoan/main amd64 Packages
... so buddha's ubuntu 19.10 can take the v6 of virtualbox, and charlie's can't.

if there was an update outstanding, you would see it in the difference between "installed:" and "candidate:"

of course we can go to a website such as pkgs.org and get a newer package, but unless you know what you are doing and do your homework, you may take a journey across the River Styx and enter

... drumroll

DEPENDENCY HELL

there are various ways of determining what depends on what, but one i like that is in our repos is

apt-rdepends

Code:
sudo apt-get -y install apt-rdepends
once installed, i can type, enter and get the following from charlie's mint, similarly with buddha's ubuntu

Code:
[email protected]:~$ apt-rdepends libc6
Reading package lists... Done
Building dependency tree     
Reading state information... Done
libc6
  Depends: libgcc1
libgcc1
  Depends: gcc-8-base (= 8.4.0-1ubuntu1~18.04)
  Depends: libc6 (>= 2.14)
gcc-8-base
... so libc6 needs to have libgcc1 installed, which in turn relies on gcc-8-base, AND a version of libc6 greater than or equal to v2.14

and libc6 also depends on having that gcc-8-base too

confused?

good :p - this is just dipping your toes into dependency hell.

the apt-rdepends command acted recursively in the above case.

we can turn that around with the following, and get it to tell us what depends on libc6.

type and enter the following and then hold on to your hat

Code:
apt-rdepends -r libc6
gone goggle-eyed?

i knew in advance that there would be a lot of output, so i entered

Code:
apt-rdepends -r libc6 > depends-on-libc6.txt
which generates a text file of that name.

going to my Nemo file manager, i open the file, which is a whopping 12.4 MB, and has

265,317 lines in it.

so libc6 has 265,000+ packages depending on it - i seriously would not muck with it, hence i have to disagree with my Green Hornet friend.

more to follow after coffee :)
WW OO WW !!!!!!!!!!!!!
I see what you mean by 'Dependency Hell'.
I entered all your codes in my terminal and 'Voila' a fast moving picture show of nothing but words flying by. LOL.
Then I did the text file thing, and went to my file manager and 'voila', an easy to read voluminous text file.
Google eyed is right, after all these things.
Believe it or not, much of what you have written makes sense to me. I don't know why, but It does. However, understanding it all will take a lot of time and study.
12.4 Mb is exactly what I show in this screenie.


Screenshot at 2020-04-05 15-37-04.png


I really do appreciate how you have helped me in my Linux trip. I don't mean to leave the others out, such as Vrai, Captain-Sensible, and all the rest.

Old Geezer - now google eyed temporarily. LOL.
TC
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
972
always welcome, friend :) - and our numbers of helpers, both willing and experienced just seem to keep growing by the day. i find it gratifying to watch. brian (condo) and i come up on 3 years here around 1 May, and it has been a wonderful part of our linux journey. :D

just a little on a reference i made earlier, before we put this baby to bed.

i said about packages dot org - pkgs.org

if you go there and take a look and search for libc6, and then go down to ubuntu 20.04 and expand it, we find

libc6focalfossa.png


... that the new LTS Ubuntu, 20.04 'focal fossa' (it's beta is out now) will be using v2.31 of libc6, hence it will run virtualbox 6.1.

our linux mint 19.3 on the other hand, has this

Code:
[email protected]:~$ cat /etc/*release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=19.3
DISTRIB_CODENAME=tricia
DISTRIB_DESCRIPTION="Linux Mint 19.3 Tricia"
NAME="Linux Mint"
VERSION="19.3 (Tricia)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 19.3"
VERSION_ID="19.3"
HOME_URL="https://www.linuxmint.com/"
SUPPORT_URL="https://forums.ubuntu.com/"
BUG_REPORT_URL="http://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/"
PRIVACY_POLICY_URL="https://www.linuxmint.com/"
VERSION_CODENAME=tricia
UBUNTU_CODENAME=bionic
cat: /etc/upstream-release: Is a directory
and you can see it is based in 18.04 ubuntu, bionic beaver, which uses 2.27 of libc6.

so as tolkem has said, it is important to get what matches your setup if you are shopping outside your repositories.

on the upside - with focal fossa out in about 2 weeks ... at Mint, historically, Clem Lefebvre and his team usually have their new LTS out by end June, so it will be based on focal fossa, have libc6 v2.31 and thus support virtualbox 6.1

HTH

wizard
 

70 Tango Charlie

Well-Known Member
Credits
161
@wizardfromoz

Thanks Wiz,
Looks like the prudent thing would be for me to wait until the new LTS comes out in June.
That's not too far away from now.
In the meantime, I can see how much of what you have posted I can come to understand.
Thanks again.
Old Geezer TC
 


Members online


Top