• We did not send an email asking for donations - please read this post.

volume always max even at 1% on my laptop



Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,116
Reaction score
4,303
Credits
30,096
G'day Toaster, Welcome to Linux.org

Which distro are you running right now ?
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,129
Reaction score
2,024
Credits
23,295
I am using POP OS
Welcome to the forums

not always the easiest to get working,
please run in a terminal inxi -A and paste back the result
you may have to install inxi from the repository, usually sudo apt-get install inxi
 
OP
T

Toaster

New Member
Joined
Apr 24, 2022
Messages
8
Reaction score
1
Credits
57
Welcome to the forums

not always the easiest to get working,
please run in a terminal inxi -A and paste back the result
you may have to install inxi from the repository, usually sudo apt-get install inxi
Audio:
Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.16.19-76051619-generic running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.32 running: yes
 

forester

Active Member
Joined
Mar 5, 2022
Messages
438
Reaction score
239
Credits
3,125
Can't run all sound servers at once. Choose one for your distro and disable the others.

For example, I know antiX uses ALSA, Slackware uses PipeWire now, and I think the 'buntus (of which POP is one) all use PulseAudio. But I could be incorrect. Start with PulseAudio
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
7,362
Reaction score
6,347
Credits
59,690
I think the 'buntus (of which POP is one) all use PulseAudio. But I could be incorrect.

You are correct, as far as the Ubuntu family. I have no idea if POP changed that.
 
OP
T

Toaster

New Member
Joined
Apr 24, 2022
Messages
8
Reaction score
1
Credits
57
Can't run all sound servers at once. Choose one for your distro and disable the others.

For example, I know antiX uses ALSA, Slackware uses PipeWire now, and I think the 'buntus (of which POP is one) all use PulseAudio. But I could be incorrect. Start with PulseAudio
I disabled pipewire with sudo systemctl disable --global pipewire
and still same issues but I couldnt find how to disable alsa
 

forester

Active Member
Joined
Mar 5, 2022
Messages
438
Reaction score
239
Credits
3,125
I don't know your distro. Maybe go to its forum and see if a similar problem has been addressed and fixed.

Search engine is your friend.
 
OP
T

Toaster

New Member
Joined
Apr 24, 2022
Messages
8
Reaction score
1
Credits
57
I don't know your distro. Maybe go to its forum and see if a similar problem has been addressed and fixed.

Search engine is your friend.
I have looked everywhere and it isnt the distro because It happens on every distro
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,129
Reaction score
2,024
Credits
23,295
We have seen many problems with Pop on this forum, Most people think it's a general distribution based on Ubuntu, But it's not, it is specially constructed to run on System 76's own hardware, as I have said many times, "if it works out of the box, then great, and if it doesn't , it's a pigs rear end to get it working correctly"
 
OP
T

Toaster

New Member
Joined
Apr 24, 2022
Messages
8
Reaction score
1
Credits
57
We have seen many problems with Pop on this forum, Most people think it's a general distribution based on Ubuntu, But it's not, it is specially constructed to run on System 76's own hardware, as I have said many times, "if it works out of the box, then great, and if it doesn't , it's a pigs rear end to get it working correctly"
I have tested other distros like fedora and manjaro on this same machine and I get the same issues so I think it is a kernel level issue.
I am not expecting a solution I am just wanting devs to know about my issue and to hope they consider a patch.
 
OP
T

Toaster

New Member
Joined
Apr 24, 2022
Messages
8
Reaction score
1
Credits
57
use sudo nano instead of sudo vi

Edit the file /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common (with sudo):

sudo vi /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

Add the following lines before the [Element PCM] block:

[Element Master]
switch = mute
volume = ignore

Kill the running daemon:

pulseaudio -k

Now you should have audio.If the daemon does not start, try to start it manually with:

pulseaudio -D

source: https://askubuntu.com/questions/973...ume-or-muted-no-middle-ground/1091197#1091197
https://www.reddit.com/r/linux4noobs/comments/ub2k1k/_/i62ga31
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top