Volume keys don't control actual sound on an i-mac

Oldcynic

New Member
Joined
Apr 26, 2022
Messages
3
Reaction score
1
Credits
42
I have Linux MInt installed on an i-mac fitted with an Intel HD 500 sound card. using OSX the keyboard Increase/Decrease/Mute keys control the sound volume irrespective of which application is producing the sound. In Linux however (any distro, Mint, Ububtu, Xubuntu etc.) only the Mute key works. Pressing either of the other 2 brings up the volume 'meter' but has no effect on the actual sound volume.
Sound has to be controlled using the Volume Control or PAVU control as follows:
Under 'Configuration' select 'Analogue Surround 4.0' from the lower window. No other option eg. 'Digital Stereo IEC 958' works. In the upper window there is a large selection of Digital options eg. 'Digital Stereo HDMI' but all are shown as 'Unplugged'.
Under 'Output Devices' the volume slider can be adjusted but it has no effect on the actual sound output.
Under 'System Sounds' various warnings etc. can be adjusted or muted and when an application eg. VLC is playing its volume appears here and can be adjusted. Unfortunately regardless of the 'Output Devices' setting this volume defaults to maximum with ear splitting results each time.
I have raised this on various distro forums with no success and I'm now convinced it is a Linux issue. Digital sound is shown as 'unplugged', is that because a driver for the Intel card is missing or is there a setting somewhere to select this card s the sound controller?
 


JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,464
Reaction score
2,082
Credits
10,249
It's more likely a keyboard/desktop related issue.
Intels sound cards are well supported in Linux.

It's probably just a case of setting-up the correct functionality to use when the key is pressed.

I haven't used a traditional Linux desktop in years, but from what I recall, the default support for media keys varies from desktop to desktop (and window manager to window manager).
So you may find that you have to take steps to define which actions to take when certain media keys are pressed.

In dwm (my tiling window manger of choice) - special/media keys are not supported at all. I had to manually add extra keybinds for the special/media keys on my laptops keyboard and my USB keyboard, in order for them to function at all.

So I've set up my playback buttons to control cmus (terminal based music player), my volume knob controls the overall system volume, the mute button mutes/unmutes the system audio. I also have special keys for opening a file-manager, opening an email client, taking a screenshot (via scrot), starting my webcam (via OBS studio) etc. etc.

A quick bit of duckduckgo-fu yielded this:
Which may be of some help to you.
The page claims it to be a "Ubuntu" related tip, but it should be relevant to any other distro running any of those desktops!
 
Last edited:

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,464
Reaction score
2,082
Credits
10,249
Key bindings are generally stored in the dconf registry. You can install dconf-editor to be able to view and edit them
Code:
sudo apt install dconf-editor
I forgot about dconf. That would certainly help for Gnome based desktops/applications!
 
OP
O

Oldcynic

New Member
Joined
Apr 26, 2022
Messages
3
Reaction score
1
Credits
42
Thank you for your replies, unfortunately I've tried and failed to re-assign the keys in the past.. The problem has to be a driver/sound card issue, I have a much older MacBook with an Nvidia card and the sound keys function normally.
As I mentioned all digital sound options are shown as 'unplugged'. Using 'Aslsamixer' in Terminal gives only the HDA Intel PCH card as a working option showing Cirrus Logic CS4208 Chip & S/PDIF (Off).
The 'Master' can be controlled by the sound keys and that is matched by the panel Volume indicator which appears but the actual sound output is not affected.
The 'PCM' and 'Headphone' columns, controlled by the keyboard "Up' & 'Down' keys, are the only ones that adjust the actual sound output. These settings are repeated in the panel Audiomixer 'Playback' tab.
Any ideas?
 

Oldhabbits

Member
Joined
May 24, 2021
Messages
60
Reaction score
44
Credits
415
What is your installed soundserver ? Pipewire or Pulseaudio ?
On my iMac I have :
Code:
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
  Device-2: Intel 9 Series Family HD Audio driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:8ca0
  Sound Server-1: ALSA v: k5.10.0-13-amd64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
 
Last edited:
OP
O

Oldcynic

New Member
Joined
Apr 26, 2022
Messages
3
Reaction score
1
Credits
42
Many thanks for that, it was Pulseaudio but your mention of Pipewire inspired me to install it and disable Pulse. Now by selecting Pro Audio on the panel Audio Mixer 'Configuration' tab the volume keys now control 'Built in Audio Pro' on the Output devices tab plus the actual sound volume of any audio media playing. 'HDMI' options still don't work but I've achieved what I set out to do.
Job done. Thanks again.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top