Wayland gaming

lomszz

Active Member
Joined
Nov 8, 2021
Messages
134
Reaction score
104
Credits
857
Okay now i have experienced myself wayland problems with Nvidia, desktop itself works good enough but games stutter so much.
If i could i would switch back AMD but graphics cards aren't free.:(

Thank god there is x11 and no problems anymore:D

Hopefully Wayland works better on future with Nvidia
 


You can use Wayland with NVIDIA drivers. Here is how to do it

Edit the /etc/gdm/custom.conf file and comment out the line WaylandEnable=false, by putting a hashtag in front of it The correct file will then look something like this:
# GDM configuration storage
daemon]
# Uncomment the line below to force the login screen to use Xorg
# WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
# Enable=true
 
Strangely enough, I have a laptop with AMD + NVIDIA graphics and games work pretty well for the most part. I'm talking Minecraft, Rocket League (a bit stuttery but usually stays over 90fps at max settings) and GTA IV (this one does stutter a lot but X11 doesn't fix it, it's a game issue)
 
I couldn't get games work with wayland for now, idk where is problem :/. Will try to fix it when I have some free time, I bet there's something to do :D
 
Hopefully Wayland works better on future with Nvidia
There is better news on the Horizon, AMD will work better than Nvidia. Agreed they aren't free, but neither is the time you wasted with the Wayland hassle.
 
There is better news on the Horizon, AMD will work better than Nvidia. Agreed they aren't free, but neither is the time you wasted with the Wayland hassle.
Probably will buy amd gpu soon, sure now everything works but still amd is better with linux, need to sell and save to buy new :D
 
You can use Wayland with NVIDIA drivers. Here is how to do it

Edit the /etc/gdm/custom.conf file and comment out the line WaylandEnable=false, by putting a hashtag in front of it The correct file will then look something like this:
# GDM configuration storage
daemon]
# Uncomment the line below to force the login screen to use Xorg
# WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
# Enable=true
I will tried this, because something similar happened to me
 
Maybe my CPU (Ryzen 5600), GPU (GTX 1650 Super 4GB), and RAM (16GB) are too puny, but I prefer to logout of my normal desktop and log back into an Openbox X11 session before gaming. This makes a noticeable difference to the game's performance (IL-2 BOX combat flight sim). Admittedly, my normal desktop is X11, but I think this would be true for Wayland too: that it's better to game in a minimal environment.
 
Maybe my CPU (Ryzen 5600), GPU (GTX 1650 Super 4GB), and RAM (16GB) are too puny, but I prefer to logout of my normal desktop and log back into an Openbox X11 session before gaming. This makes a noticeable difference to the game's performance (IL-2 BOX combat flight sim). Admittedly, my normal desktop is X11, but I think this would be true for Wayland too: that it's better to game in a minimal environment.
I'm too lazy to always logout.
:D
 

Members online


Top