Why Isn't Netdiscover Working On My Virtual Machine?


New Member
Nov 7, 2018
Reaction score
I am doing a vulnhub CTF walkthrough (Lampiao). I have my main VM set up using Kali Linux in VirtualBox. The victim VM is the Lampiao machine. I am supposed to run Netdiscover on Kali to search for the IP's of all machines on my network. I have both machines set to NAT.

When I run Netdiscover from Kali, it doesn't pick up anything at all. I do have internet though and if I run ifconfig my IP is not a 192.168.x.x, its a 10.x.x.x. If I switch to bridged or host-only, then I lose internet completely. I can't ping anything.

Why is this happening?

And are there any specific settings that I need to make sure to always have on my VM's so that they can see each other?

If all you want is to have two VMs in VirtualBox see each other you can choose option in network configuration "Internal Network" and give both of them the same name. Then, you will need to assign IP address from the same network range (for example on first and on second). You will be able to communicate between VMs only, not from Host to VMs or from VMs to Internet.

In the "Host-only" configuration your VMs will connect to virtual adapter created by VirtualBox on your Host. Again you need to assign IP addresses from the same network range on your Host and on your VMs to be able to communicate. You can also configure DHCP service in VirtualBox settings for this type of connection. This will not allow you to connect to Internet from VMs.

If you choose "Bridged", than VMs will directly attach to your physical network interface. To be able to communicate you will need to assign them addresses from the same network as your physical card have (if you have DHCP in your network it should assign addresses automatically). This type will allow you to connect between VMs, Host and Internet as well

Members online