wlan network interface not showing

ttrss

New Member
Joined
Dec 9, 2021
Messages
2
Reaction score
0
Credits
23
Hi, I recently installed arch on my laptop. It lacks an ethernet port so I've had to use wireless, It's been working on and off for a few days but now the wlan interface won't show when I run 'ip link'. I can see it's been detected in lspci and it is written, 'Kernel driver in use: iwlwifi'. It's called Intel corporation wifi 6 (Rev 20).
Lspci https://prnt.sc/22d2zmk
Ip link https://prnt.sc/22d34k9

In both journal an dmesg it repeats 3 times that it failed with code -2 but then it says it did load the firmware and detected my wifi card and shows the hardware address.
To configure the network originally, I unblocked the interface from rfkill then "ip link set wlan0 up" then setup dhcp with dhcpcd then finally iwctl and it worked.
Also I did install linux-firmware with pacstrap.

Thanks for any help you can provide
(Also, if it's not apparent, I'm on a laptop)
 


brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,582
Reaction score
1,174
Credits
11,891

arochester

Moderator
Gold Supporter
Joined
Apr 25, 2017
Messages
1,578
Reaction score
1,250
Credits
2,722
Is it called "wlan0"? Some distros have changed away from that.

Try: ip dev

My laptop has no Ethernet port, but I can use a cheap Ethernet/USB connector from eBay.
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
623
Reaction score
558
Credits
4,377
Hello ttrss,
Welcome to the forums, Don't do arch but which wifi card is in the machine?
 
OP
T

ttrss

New Member
Joined
Dec 9, 2021
Messages
2
Reaction score
0
Credits
23
Well in the screenshot it says Intel(R) Wi-Fi 6 AX201 160Mhz
 

brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,582
Reaction score
1,174
Credits
11,891
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top