Yum Update failing...

junishpv

New Member
Credits
62
Hi Guys,
If anybody here to share some possible causes with this. I am working on my VM (VirtualBox), which is running with "CentOS Linux release 7.9.2009 (Core)". I have removed a couple of repos (doesn't require by the product I am testing with) manually from /etc/yum.repos.d to morning. Then, I did yum clean and followed yum update.

#don't think so my changes in the /etc/yum.repos.d caused this..I am sure about the repos that I have removed, I didnt touch any centos repos..
#not sure whether it is happening because of IP6 lookup..
# I dont have /etcgai.conf file anyway..

Or do I need more coffee to wake me up :) :)
Can somebody help with this..????
The yum update is throwing this error:
============

[[email protected]]# yum update
Loaded plugins: fastestmirror
Determining fastest mirrors
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock error was
14: curl#7 - "Failed to connect to 2a05:d012:8b5:6503:9efb:5cad:348f:e826: Network is unreachable"


One of the configured repositories failed (Unknown),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Run the command with the repository temporarily disabled
yum --disablerepo=<repoid> ...

4. Disable the repository permanently, so yum won't use it by default. Yum
will then just ignore the repository until you permanently enable it
again or use --enablerepo for temporary usage:

yum-config-manager --disable <repoid>
or
subscription-manager repos --disable=<repoid>

5. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/x86_64
=============
 


f33dm3bits

Gold Member
Gold Supporter
Credits
25,562
What's the output of yum repolist and do you have ipv6 configured on your system or just ipv4?
 

junishpv

New Member
Credits
62
Actually, I want to be a bit more specific here. Later on, what I found was funky iptables rules. After the changes I made for my testing purpose, it started blocking my outgoing connections from device 'eth0'. So upload another rule (outerface eth0 ACCEPT; ) to solve that and worked!!. worked even rolling back ipv6 lookup.

love these crazy firewalls.. :)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top