Adjust Trackpoint speed on Lenovo P70 / Ubuntu 22.04


New Member
Apr 1, 2022
Reaction score
I recently had to replace a failed keyboard on my Lenovo P70 running Ubuntu 22.04. Generally, everything is working fine, with one exception. The trackpoint (eraser in the middle of the keyboard) is VERY slow and I can't figure out how to adjust it. First I tried turning the speed up for both the touchpad and the mouse in the 'mouse and touchpad' settings dialog. The touchpad changes did take effect, though I don't use the touchpad so that's not much help. I don't use an external mouse, but I did confirm that those settings had no effect on the trackpoint. I've googled around a lot and tried a couple of things, but it seems like most of the suggestions are pretty old at this point, I'm skeptical that they are still relevant to 22.04.
Here is the output of 'input':
ThinkPad-P70:~$ xinput
WARNING: running xinput against an Xwayland server. See the xinput man page for details.
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ xwayland-pointer:16 id=6 [slave pointer (2)]
⎜ ↳ xwayland-relative-pointer:16 id=7 [slave pointer (2)]
⎜ ↳ xwayland-pointer-gestures:16 id=8 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ xwayland-keyboard:16 id=9 [slave keyboard (3)]
It's not even clear to me if one of those devices is the trackpoint. If so, which one?
Anyway, if anyone has any suggestions about how I could move forward here, I'd really appreciate it!

I did a quick search:

That's unverified by me personally. Look specifically at section 3.1.1 and that's promising.

Members online