Error on boot: uefi db list


New Member
Jul 25, 2019
Reaction score
When booting I see some error on startup which I never get to read entirely because it goes away really quick. I do get to read something that says "couldn't get uefi db list".
My laptop does boot after displaying this error and all things seem to be working fine.
I do get the same error when powering off, and when logging off.
Oh, I'm running Deepin on a macbook pro of 2015, so no secure boot.
Last edited:

My laptop does boot after displaying this error and all things seem to be working fine.
Hi @BoredPanda, and welcome. A wise old Unix geek once said, "If it ain't broke, don't fix it." :D

The startup and shutdown sequences can be looking for many things, including things are not even available on your computer... so they can look like an error when really it isn't. Many Linux distros mask those sequences and just show the logo graphic, so it really isn't critical to look at the reports as they fly by on your screen, or to try to evaluate them.

If your Linux is working good, just enjoy the ride!

Lol, I thought so at first but then I got worried that if I ignored it would come and bite me in my behind later.
Since it doesn't hurt to ask, I thought I'd ask the experts around here.
Thanks for answering!
Another thing you could try is looking through the dmesg log.

It may provide some some clues, show warnings and or errors with details.

Linux Deepin is still based on Debian unstable (Sid) right?
If you want to see the message as it appears on your screen, and hold it there, use your phone and video it. THen when you replay it, you can stop it just at the right moment. :)

That's not to say that you shouldn't just ignore it like Atanere suggested. I have an error that pops up on my computer during boot. It's been there thru multiple installations. And like Atanere suggests, I've just ignored it.
Hey you all! I managed to take a picture, this is what I see on boot:

Oh, I'm running Deepin on a macbook pro of 2015, so no secure boot.
I've never owned a Mac, but their hardware does not always play well with Linux... or at least not as well as standard PC hardware. The first thing in your screenshot is "Firmware bug".... and that indicates an issue with your UEFI (aka BIOS). Another issue (possibly related) is ACPI (Advanced Configuration and Power Interface). The Wikipedia link given states, "ACPI brings the power management under the control of the operating system" (taking this management away from UEFI/BIOS).

I don't know if you have noticed before, but this hints you might have trouble with power management options, such as suspend or hibernate. I've never been a fan of those "features" myself anyway, and they are known to be wonky with Linux in standard PC hardware too, so no surprise if you have trouble with it too.


1. Continue to ignore it as long as you're satisfied with the computer operation.
2. Investigate/change power settings (ACPI) in UEFI settings. You might find the magic setting.
3. Try GRUB settings for ACPI, such as noapic or acpi=off or both.
4. Try a different distro. Since it is the OS taking on power management responsibility, a different distro might have a better handle on your Mac's firmware.
Thank you for taking the time to explain everything so clearly! I really appreciate it.
I'll try what you've mentioned and update this post as I go.
Last edited:
I've changed the grub settings for ACPI and, following directions found in a similar post, I updated the grub and the kernel. This is the message I got in return. Should I be worried?
Should I be worried?
Heck, I wasn't worried from the first screenshot showing the UEFI/ACPI errors. :D Did the modification(s) to GRUB fix those errors? That is, do you still see them when booting?

I'm not too worried about these errors either as long as everything is running okay. I might have taken your steps sequentially... 1. Change GRUB... fix problem? (If yes, stop). 2. If problem remained, then update kernel. But no matter.... I would not try to revert the kernel either unless there are problems.

This new error report comes from the kernel update, right? If yes, then you'll likely never see this report again unless there really are some more issues. Nothing here looked like it came from the GRUB boot sequence.

How is Deepin running for you?
Lol, the word "warning" in caps made me freak out. Thank you for being so patient! I've asked for help in other forums in the past regarding other issues but their answers are always so condescending.

I haven't rebooted yet, had to pit a pin on that. I changed the setting of acpi to strict because it was highly recommended on some forums. What does this setting do? Do you think the ones you suggested would be better?

Deepin runs good, some minor bugs like the hot corners not working sometimes but overall I've had no problems.

Thank you again, Atanere :)
Last edited:
...but their answers are always so condescending
We all have good days and bad days, I guess... the nature of people. I like to joke around a bit, but I can tell that sometimes I am not so amusing to others. (I crack myself up though!) :eek:o_O:D

I changed the setting of acpi to strict because it was highly recommended on some forums. What does this setting do? Do you think the ones you suggested would be better?
Editing GRUB with these changes is instructing the kernel to operate with different parameters when it boots and takes control of the system. There are a handful of common parameters like these that folks find necessary to make their hardware and OS play nice together. I don't know exactly what the ACPI instruction means to the kernel, or what the difference entails between "off" and "strict"... but try them both if the boot error is still appearing. And let us know which, if either, helps out.

Besides ACPI and power issues, one of the most common reasons to pass extra parameters to the kernel is because of video card issues, and most especially with NVidia.

...but then I got worried that if I ignored it would come and bite me in my behind later.

Suggestion - take to wearing concrete underpants.

G'day Panda, Hi Stan :)

Panda when you settle on an altered Grub (/etc/default/grub), maybe post us a copy of what it looks like so we can see it's OK.

Your screenshots are good, but a suggestion on representing textual output -

From Terminal, copy and paste the text, including your command, straight into your Reply field, and using Codes.

Codes can be found in your toolbar just right of the emoji sign, the drop down menu also includes Spoiler, which is great for long output such as log content.

By putting the text in Codes, it makes it easy for us to eg copy a line and say "instead of this, put that".

The screenshots are best for graphical representation (and are worth a 1,000 words) eg GParted windows, etc.


Wiz, and

Okay, so now my pc boots but I can't do anything at all. I can't move my cursor, I can't open terminal. Nothing!
The last thing I changed was my acpi setting. Is there any way I can change it back by accessing some menu on startup?
Should be. Since you are on a Macbook, do I take it you are also running MacOS? Or is it just Deepin?

If the former, then a Grub Menu is presented to you at startup where you can choose either Deepin or Mac.

If the latter, and Deepin is the sole OS, then Grub Menu is hidden by default, but we can get it to reveal itself.

Once we have the Grub Menu available, just use an arrow key to move the highlighted choice so we cancel the countdown, then take a look at the bottom of your screen.

There will be options of c for command, e for edit, etc.

Choose e for edit you will be taken to another screen that shows startup parameters and it will include a line starting with linux that shows the changes you made regarding apic.

Use your arrow keys to backspace or delete the apic reference, then F10 to save and reboot.

Enter Deepin, and edit the /etc/default/grub file to likewise remove the apic reference, then exit the file and run

sudo update-grub

When you reboot, you should be returned to where you were in the beginning, with a non-fatal warning.

Let us know how you go.


Deepin is my sole OS. I read that I'm supposed to press either esc or shift on boot but nothing is happening :(
Typically it is a case of repeatedly tapping, or sometimes holding down, Left Shift or Right Shift, but it varies from computer brand to computer brand and I am uncertain on Macbooks.

EDIT by Wizard - the above refers to MBR(Legacy) computers, with UEFI it is typically the ESC key. My bad.

Can I do it from a live usb?

Not easily, we would have to teach you how to chroot in from the Live to your system, and then edit and save the file.

It might be just as easy to reinstall Deepin from scratch.

Let us know which course you want to try.


BTW - edited error above. Wiz
Last edited:
I mounted my efi partition from the live usb, and I'm trying to edit the grub.cfg file so I can change the grub timeout setting (currently 0). I'm using this post as guide:

I'm stuck because:
There are 4 folders within EFI and three of them have a grub.cfg file and neither of these files has a timeout setting which I can edit. They all look like Photo#2


Last edited:
Also, feel free to delete my other post. I tried to do it myself but I can't find the option.

I'm thinking that once I change the timeout I can just follow the steps you gave me above.

Members online

Latest posts