Fedora 29 WiFi


New Member
Jan 5, 2019
Reaction score
So I'm super new to Fedora. I have a fresh install and the Os seems to be lacking a driver for my WiFi card. the system sees the installed hardware but it doesn't appear under network. I ran the lspci -v command and got this as part of the output.

02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43228 802.11a/b/g/n
Subsystem: Dell Device 0014
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at f7e00000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: bcma-pci-bridge
Kernel modules: bcma

I could use some detailed help.

G'day @P@P@sad00ski and welcome to linux.org :)

I am not a Fedora expert (nor wifi :() but I have a Fedora 29WS on board I can swing over to a little later in my Friday.

A Google search under

fedora wifi BCM43228 solved

... suggest some leads.

There is/was an rpmfusion repository which included


which is likely to support your card.

Both Broadcom and Realtek can be a little problematic with Linux and how frequently they release to us information that we can incorporate into the Linux Kernel can determine whether a card is supported as quickly as we would like it to be.

Chris Turner
So, I ran the broadcom-wl command and I ran sudo broadcom-wl command and got command not found both times. Now what? Do I need to swap over to Lubuntu? I would really like to get Fedora running on this thing.
do you have wireless-tools installed? What is output from "iw list" ?

Members online