Solved Grub not installed correctly

Solved issue


New Member
Sep 9, 2023
Reaction score
I bought a 240gb SSD to install linux on it and booting it from a usb 3 port . But while trying to install kali everything seems to go normal until the grub bootloader installation. I've installed kali before for quite tens of times but this time i am installing it from a vm directly to the ssd just for safety because the pc isn't mine . However grub says that it is installed normally but when selecting the boot devices i only see windows boot manager. Yes secure boot is disabled and tpm too . Can't i fix it via just booting a live kali image and reinstall it ?

And the weird thing is it shows that it is installing grub dummy .

Ps: I'm using virtual box for this one . I'm used to using vmware and I'll try installing via vmware if I don't get comments and responses soon enough. And I'll keep you updated:)

And pls if you are going to tell me if I can't fix simple problems don't use kali . Man I'm not looking for trouble.

You are the forth to ask this question in the last couple of days
go to the kali subforum [link below] AND READ the first 2 post, then read the 3rd post


Staff online

Members online