!HELP! Virus blocking acces to most websites


New Member
Jan 19, 2018
Reaction score
Hi there,

I really need help. I am new to Linux and i am not yet used to work with the terminal and how linux works compared to windows.

I use linux mint cinamon.

I think i have a virus that blocks most websites. It started today.

Mabye its because i installed and allowed java, to play some browser games.

I already installed clamav+clamtk but i am not able to update the antivirus signatures because i can not connect to the servers. I also can't download
"WARNING: Can't download main.cvd from db.local.clamav.net"

I also looked up some youtube "internet problem fixing" with the dns, but that seems to be not the problem.

I don't know what else i can do.

You help would be really appreciated.

G'day Emergency, and Welcome to Linux.org

Uninstall clamav and clamtk.

Reboot after the uninstalls.

See if you can access websites now.

The reason I have taken this approach is because I had the clam product installed long ago just after i moved to linux from windows, and I experienced nothing but weird trouble.

Also....Linux is fairly impervious to virus's and pop ups etc etc.....practise Safe Surfing and you will generally stay out of trouble. This is one of the huge differences between Linux and windows.

Please be sure that the firewall is enabled.

Open terminal (ctrl+alt+T) type in ::

sudo ufw enable

(copy and paste so you get the spacing right)

you will be asked for your password.....
Type it in......you will NOT SEE any letters, numbers etc...this is normal

Take a look at this page it is Ubuntu's page....but it applies to Linux as well.(as do a lot of ubuntu pages..)

That will do you for now....get the firewall in place ands you will be quite safe. That is all I run and I am quite sure that most if not all others here will be the same
Just for the record, I have not added any "rules" to my firewall....the ufw stands for uncomplicated firewall....and that is the way I keep it. Pic below (note that mine is already installed of course.)

Hi Condobloke,

Thanks for your friendly advice.

I don't think deinstalling clamav and clamtk will help with my problem, i just installed them because i got the problem.
Anyway i deinstalled them and set up the firewall like you suggested.

I still can't access most websites.
Hi @Emergency, and welcome to the site! It sounds like one of those java games could be the culprit.... they will sometimes "hijack" the browser and limit your ability to surf. If you're using Firefox, open the settings and go to Add-Ons. From there, look at your Extensions and Plugins for a rogue app that you did not install. If you find one, uninstall it and restart Firefox. Hope that will fix it for you.

Which version of Linux Mint are you using.....17.1.....17.3....18.1....etc ?
Thanks for you fast help guys!

couldn't find a application that didn't belong there. Also i have the same problem with chromium browser not just firefox.

@ condobloke:
I use Linux Mint 18.1 KDE 64-bit (cinnamon)
How old is this install ?....Did you "Verify" the iso file ?

How did you install and allow java....what procedure did you follow to do that ?

Have you tried uninstalling Java ?

(and your install is either KDE or Cinnamon)
i installed it half a year ago. No i didn't verify the iso.

About java, i don't really remember, it was really difficult for me, i needed 2 days to make it work, i tried different ways i found on the internet until it worked.
I have a "IceTea-Web Plugin" and "Shockwave-Flash" in my plugins on firfeox. Shockwave tells me its vurnerable and needs to be updated but when i click on "update" it can't load the webiste for the update.

For allowing: everytime i go on a website that needs the java plugin it gets blocked, then i manually allow it in a little firefox "popup".

About my linux version: i thought i installed cinnamon, but my terminal says: Linux Mint 18.1 KDE 64-bit.

I will try to deinstall java now and report back to you.
reboot after uninstalling java.....in fact reboot a couple of times.

and....has this problem accessing websites only occurred since installing java ?
The problem with deinstalling java: I don't know the exact name of what i need to uninstall.
"sudo apt-get remove java" didn't find anything to remove.

In my application manager i can find something called "Run Java" but i don't know how to find the path to the program.

The problem with accessing websites is just since today, i installed java a couple of weeks before, yesterday i tried a new browser game and downloaded an free e-book. i think one of these 2 sources could be the problem.
while you are doing that.....

I am not familiar with the KDE environment.....but I am hoping it is similar to Cinnamon. If you click on menu, it should have a 'software manager' in there somewhere....type 'Java" into the search box in the software manager.....and hopefully the first result will be 'Eclipse, extensible tool,platform and Java IDE'
Is that similar to what you have ?
Please note.....important....that all Linux 'flavors' ....have a software manager......they draw an amazing number of programs from the repository. They are free, and install usually with one click. if you dont like the result they uninstall with another click (or two)
if you type JAVA in to the app manager.....what result do you get ?
Yes i have the software manager, first result is eclipse. I haven't installed it, i think i tried installing java through the software manager but i it didn't worked, but i don't really remember.

i always try the software manager first, but i often don't find what i am searching there.
On the "Run Java" app....try right clicking that and select Uninstall....
When i type "Java" in the app launcher just "Run Java" and a couple of e-books not related to java.

Right click on the "Run Java" doesn't work.
ok.....I am out of ideas...for now.........and I have an early start tomorrow morning. I am in australia, so my time is prob a little different to yours

More people will come along. Dont panic.
Sorry for my delay... had to leave for work. Sounds like you guys may well be on the right track looking at Java.

But, if you would humor me for a moment, I would be interested to know if Firefox will let you surf in "safe mode." First close Firefox, open a terminal and enter:
firefox -safe-mode


Latest posts