https connection (port 443) to file server is unstable and slow.

andrewysk

Member
i need to connect to https file server.. but the nemo is no good at it.
everytime i tried to download (copy) several files of few file of 100MB each, it will just starts and stuck not even half way. and stuck forever.
i have also tried to download 1 file (100MB) at a time, and sometime it works, the other time it download at 3MB / sec and then get stuck again before even reach half.. download speed is horrible slow and connection is unstable.


it download audio file of 10MB fine without any problem.

any body know how to solve the problem ?

Code:
$ inxi -SMA
System:
Kernel: 5.3.0-42-generic x86_64 bits: 64
Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
Type: Laptop System: HP product: HP Laptop 15-da0xxx
v: Type1ProductConfigId serial: <root required>
Mobo: HP model: 84AA v: 82.22 serial: <root required>
UEFI [Legacy]: Insyde v: F.04 date: 08/02/2018
Audio:
Device-1: Intel driver: snd_hda_intel
Sound Server: ALSA v: k5.3.0-42-generic
thx
 


andrewysk

Member
hii, i am using nemo to download, there is a "connect to server"option in nemo.
the file server is not mine, hence no admin access, i just have user access, so no error logs..

the problem could never be on the server, but on my own client software. because i can download all files fast and problemless on windows os using "winscp". since i would like to switch to linux, i need it to work.. but so far, i can't find any software for https download on linux, nothing free.
and sadly nemo itself also of not much use.

andrew

What are you using to download the files - web browser? Could you use curl or something with increased logging to see if there are any errors?

What software are you using on the file server? Are you seeing any errors in the logs there?
 

andrewysk

Member
Code:
$ nemo

(nemo:13749): Gtk-WARNING **: 16:55:49.419: Failed to register client: GDBus.Error:eek:rg.gnome.SessionManager.AlreadyRegistered: Unable to register client
Nemo-Share-Message: 16:55:50.429: Called "net usershare info" but it failed: 'net usershare' returned error 255: mkdir failed on directory /var/run/samba/msg.lock: Permission denied
net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.
it there anything related to https file transfer ?

on the other hand, when i
Code:
$sudo nemo
then i click "connect to server", it prompts this error msg

5780


i can't even enter https connection data.


and this is what is shown on terminal:
Code:
$ sudo nemo 
Nemo-Share-Message: 16:58:28.841: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.
Gtk-Message: 16:58:31.848: GtkDialog mapped without a transient parent. This is discouraged.
Gtk-Message: 16:58:54.352: GtkDialog mapped without a transient parent. This is discouraged.
Gtk-Message: 16:58:59.129: GtkDialog mapped without a transient parent. This is discouraged.
Gtk-Message: 16:58:59.362: GtkDialog mapped without a transient parent. This is discouraged.
Gtk-Message: 16:59:07.829: GtkDialog mapped without a transient parent. This is discouraged.
Gtk-Message: 17:01:19.586: GtkDialog mapped without a transient parent. This is discouraged.
Gtk-Message: 17:01:27.223: GtkDialog mapped without a transient parent. This is discouraged.
when i closed the "elevated" nemo these displayed on terminal:

Code:
Gtk-Message: 17:05:17.370: GtkDialog mapped without a transient parent. This is discouraged.
Running Firefox as root in a regular user's session is not supported.  ($HOME is /home/xuna which is owned by xuna.)
Running Firefox as root in a regular user's session is not supported.  ($HOME is /home/xuna which is owned by xuna.)
Running Firefox as root in a regular user's session is not supported.  ($HOME is /home/xuna which is owned by xuna.)
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: iceweasel: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: seamonkey: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: mozilla: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: epiphany: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: konqueror: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: chromium: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: chromium-browser: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: google-chrome: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: www-browser: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: links2: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: elinks: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: links: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: lynx: not found
/usr/bin/xdg-open: 851: /usr/bin/xdg-open: w3m: not found
xdg-open: no method available for opening 'http://www.linuxmint.com/documentation.php'

are these the output you asked for ?

btw, filezilla free version has got not https support.
only pro version of filezilla supports https, which need to pay.


thx



hii, i am using nemo to download, there is a "connect to server"option in nemo.
the file server is not mine, hence no admin access, i just have user access, so no error logs..

the problem could never be on the server, but on my own client software. because i can download all files fast and problemless on windows os using "winscp". since i would like to switch to linux, i need it to work.. but so far, i can't find any software for https download on linux, nothing free.
and sadly nemo itself also of not much use.

andrew

What are you using to download the files - web browser? Could you use curl or something with increased logging to see if there are any errors?

What software are you using on the file server? Are you seeing any errors in the logs there?
You have a few options.. you could start nemo from a terminal - it should log errors in the output there. Alternatively, you can use filezilla and connect using sftp protocol. Should be nice and quick.
 




Top