• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Solved Kernel upgrade issue on Linux Mint 20.3 with encrypted root fs

  • Thread starter Deleted member 147986
  • Start date
Solved issue
D

Deleted member 147986

Guest
Been stuck on kernel 5.15.0-48 now for half a year or so unable to install later ones, because the later ones refuse to boot with the encrypted root filesystem chosen during installation. No prompt appears to enter the password. Black screen and nothing.

Is there some way to fix this issue or am I just frozen forever on this kernel version on Linux Mint 20.3?
 


I don't encrypt anything so I never get problems...if it was me I'd do a clean install of Mint 21.1 and don't encrypt anything.
m1212.gif
 
What @bob466 said above. Agreed.
 
Using the Mainline kernels doesn't seem like a good idea considering it states they are not supported and not for production use.

Once backups finish syncing I'll reinstall with Mint 21.1 as it seems like the easiest way to deal with this issue.
 
Using the Mainline kernels doesn't seem like a good idea considering it states they are not supported and not for production use.
It's not like you are running a company where thousands of users connect to your Ubuntu system. It also states.
You should only install these if they may fix a critical problem you’re having with the current kernel.
Since this installing a more recent kernel fixed the issue for a person running Fedora with an encrypted drive, it sure is worth a try to see if it will fix your issue. If it doesn't you have tried it and you can uninstall it again, if it does you problem will be have been solved you can't lose either way.
Also if you want official support you can always also still try the HWE kernel which is officially supported and you could try that one as well if you wanted something supported.
The solution? Offering different kernels for different users. Therefore Ubuntu will offer at least two kernels: the General Availability (GA) kernel, i.e. the most stable kernel, which does not get updated to point releases; and the Hardware Enablement (HWE) kernel, i.e. the most recent kernel released. This is why you are seeing both the linux-generic and the linux-generic-hwe packages.
 
Last edited:
Installed Mint 21.1 and the issue has disappeared. Was planning to anyway since it's a LTS release.

5.15.0-56, 5.15.0-72, 5.19.0-41 all work normally prompting for the password on boot as expected.
 
@Insomniac

If you are happy with the outcome, just go to your first post, choose Edit Thread and click No Prefix and choose Solved.

naldBkx.png


Cheers

Wizard
 

Members online


Top