Locked Drive After moving to Linux from Windows [HELP] [Pop-OS]

User206130723092

New Member
Joined
Jun 7, 2021
Messages
25
Reaction score
8
Credits
167
I have been looking, and looking but I cant find an answer that would help.
Folder Located under: /mnt/Drive

So in the Terminal I typed: ls -l
drwxrwxrwx 1 root root 4096 Aug 6 23:14 Drive​

I tried Chown, on it but it said:
sudo: /etc/sudo.conf is owned by uid 1000, should be 0​
sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set​

Also tried "pkexec visudo":
pkexec must be setuid root​

And tried doing Both again with"su" but did not work:
pkexec must be setuid root​

Help Please
 


Tolkem

Well-Known Member
Joined
Jan 6, 2019
Messages
1,450
Reaction score
1,176
Credits
10,528
The title of the thread, and the contents, are two whole different things; tittle says "locked drive", then you post some commands to do something that has nothing to do with a "locked drive". Can you explain what your problem is? Cause as it is right now, I've no idea what you're talking about.
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,030
Reaction score
867
Credits
7,330
Hello User206130723092, Welcome to Linux.org
And while your at it which Linux distro are you using? Give us some info on the system also is it an HDD or SSD (nvme?) ?
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,757
Reaction score
1,175
Credits
13,083
Looks like to me that you tried to mount a drive and cannot change the permissions to it?
What is the output of
Code:
sudo blkid -c /dev/null
My thinking is your mount point and the mounted file system is vfat. So you are trying to write meta data to a file system which the file system does not support (i.e. cannot store). Simple as that.
What CHOWN Command did you run - was it similar to sudo chown [username] -hR / ? the reason I ask is the following line -sudo: /etc/sudo.conf is owned by uid 1000, should be 0 and sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set - this indicates to me that you have trashed out your permission structure of your entire system - Seems to me that you need to get Sudo working first - it looks like to me that when you ran CHOWN you changed the permissions of Sudo is no longer owned by root
Change the owner back to root:
Code:
pkexec chown root:root /etc/sudoers /etc/sudoers.d -R
reboot
 
Last edited:
OP
U

User206130723092

New Member
Joined
Jun 7, 2021
Messages
25
Reaction score
8
Credits
167
Hello User206130723092, Welcome to Linux.org
And while your at it which Linux distro are you using? Give us some info on the system also is it an HDD or SSD (nvme?) ?
Looks like to me that you tried to mount a drive and cannot change the permissions to it?
What is the output of
Code:
sudo blkid -c /dev/null
My thinking is your mount point and the mounted file system is vfat. So you are trying to write meta data to a file system which the file system does not support (i.e. cannot store). Simple as that.
What CHOWN Command did you run - was it similar to sudo chown [username] -hR / ? the reason I ask is the following line -sudo: /etc/sudo.conf is owned by uid 1000, should be 0 and sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set - this indicates to me that you have trashed out your permission structure of your entire system - Seems to me that you need to get Sudo working first - it looks like to me that when you ran CHOWN you changed the permissions of Sudo is no longer owned by root
Change the owner back to root:
Code:
pkexec chown root:root /etc/sudoers /etc/sudoers.d -R
reboot
So I've find some more information that might help. My drive is not locked but a folder is (My Games). The permissions on it is "drwxrwxrwx 1 root root 4096 Jul 15 20:59 'My Games'". The Drive is already mounted when I moved over.

Sorry for any misinformation, I'm new to linux still. (7 Days)
I'm using Pop!_OS 21.04, 64-bit
GNOME Version: 3.38.5
Windowing System: X11
Graphics: NVIDIA Corporation GP106 [GeForce GTX 1060 3GB]


My Hard Drive: HDD
Drive Model: ST2000DM008-2FR102 (0001)
Serial Number: ZFL3YNZG
Assessment: Disk is OK, 16 bad sectors (42° C / 108° F)
Size: 2.0 TB (2,000,398,934,016 bytes)
Partitioning: Master Boot Record
Contents: NNFS - Mounted at /mnt/Drive
UUID: 767C11D57C11914B
Partition: NTFS/exFAT/HPFS
Edit: The command that you gave me, did not work​
 
Last edited:

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
1,004
Reaction score
1,134
Credits
9,370
So I've find some more information that might help.
No, it doesn't help. As @Tolkem asked, "What exactly is the problem you are having?"

The "My Games" folder is not locked. It is owned by root, but the permissions you show tells us that anyone can access the folder and read/write into it.

Please describe what does not work, or what you cannot do on your system. What Linux distro are you using?
 
OP
U

User206130723092

New Member
Joined
Jun 7, 2021
Messages
25
Reaction score
8
Credits
167
No, it doesn't help. As @Tolkem asked, "What exactly is the problem you are having?"

The "My Games" folder is not locked. It is owned by root, but the permissions you show tells us that anyone can access the folder and read/write into it.

Please describe what does not work, or what you cannot do on your system. What Linux distro are you using?
I cant access it.

Edit: It just says "Error while Copying. Permission Error"
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
1,004
Reaction score
1,134
Credits
9,370
Where is it? Is it in the "Drive" folder you show in the Hard Drive Report above? This report above shows it as "NNFS - Mounted at /mnt/Drive"... and I don't even know what NNFS is. (NTFS?)

Are you trying to look at your Windows partition from Linux? That might explain things, but I'm only guessing.
 
OP
U

User206130723092

New Member
Joined
Jun 7, 2021
Messages
25
Reaction score
8
Credits
167
Where is it? Is it in the "Drive" folder you show in the Hard Drive Report above? This report above shows it as "NNFS - Mounted at /mnt/Drive"... and I don't even know what NNFS is. (NTFS?)

Are you trying to look at your Windows partition from Linux? That might explain things, but I'm only guessing.
Its under Drive/Documents/
And I'm just Tying to copy it over.
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
1,004
Reaction score
1,134
Credits
9,370
Copy from where? From Windows?

Copy to where?
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
1,004
Reaction score
1,134
Credits
9,370
I'm sorry, I'm still not getting it. What do you mean by "my drive" ?

If you are trying to copy files/folders from a Windows drive to Linux, there can be problems. The one I'm thinking of is easy to work around, but I'm not sure what you're doing. I understand you are very new to Linux, so I know it can be hard to understand.

Let's start again here:

1. Did you install Linux on your computer hard drive? Or are you running Linux off of a USB flash drive?

2. Which Linux distribution are you using?
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
1,004
Reaction score
1,134
Credits
9,370
Okay, and what "drive" is mounted at /mnt/Drive? Is this an external drive plugged in with USB? Or is this computer "dual booting" with Window and Pop_OS? Put another way... is /mnt/Drive your Windows partition?
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,030
Reaction score
867
Credits
7,330
It looks like the folder is owned by root and I don't know what NNFS file system is.
you will have to open Nautilus as root. you can do that with this command in a terminal
Code:
pkexec Nautilus
enter your user password when asked. Be careful as you can move most any file with nautilus in this mode and moving or deleting some will break your system.
You should also be able to copy the file using the terminal if you like with This command
Code:
sudo cp /mnt/Drive/Foldername
If you copy it to your home folder you may still need to change the permissions for the Folder. Good Luck.
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
1,004
Reaction score
1,134
Credits
9,370
@Lord Boltar's advice above may fix this, but if you will try this... open a terminal and type:
Code:
sudo su

Give your password (you may or may not see any **** characters echo). You should see the end of your "prompt" change from a $ symbol to a # symbol. This makes you the root user.

Try your copy command again and see if it works.
 

Thunderpants

New Member
Joined
Aug 7, 2021
Messages
17
Reaction score
16
Credits
140
Rebooting Windows10 and disabling 'fast startup' solved this problem for me when booting Linux. Plenty on the web on how to disable this option.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top