NetworkManager - No suitable device found for this connection

Dommy

New Member
Joined
Aug 30, 2020
Messages
2
Reaction score
0
Credits
42
Connection activation failed when using establishing wifi connection


I am using NetworkManager on the command line to add wifi connections and use them.

I have tried to add a wifi connection.
I can scan it and I can add it. But I cannot seem to start it.

I add it on the command line like so:

nmcli device wifi connect "FRITZ!Box 3490" password "6546546546"

I can see it is added by:

nmcli con show

NAME UUID TYPE DEVICE
Wired connection 1 772d194a-0436-3c10-b962-1eb051b934da ethernet eth0
FRITZ!Box 3490 a2f9ef1e-e2c1-4b2f-ae09-a92c7fa23519 wifi --



If I try to start it with:

sudo nmcli con up 'FRITZ!Box 3490'

I get this error:

Error: Connection activation failed: No suitable device found for this connection (device eth0 not available because profile is not compatible with device (mismatching interface name)).

Using ifconfig I can see:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.178.110 netmask 255.255.255.0 broadcast 192.168.178.255
inet6 fe80::9e1f:8199:8d06:445 prefixlen 64 scopeid 0x20<link>
ether dc:a6:32:af:d4:eb txqueuelen 1000 (Ethernet)
RX packets 17569 bytes 16539054 (15.7 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 15990 bytes 5258054 (5.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 1535 bytes 1215305 (1.1 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1535 bytes 1215305 (1.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether c2:1f:f0:7a:ed:15 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


So I look at the logs:

sudo journalctl -fu NetworkManager

I get this:

<warn> [1598862816.7794] device (wlan0): re-acquiring supplicant interface (#4).
<error> [1598862817.0310] sup-iface[0x14888f0,wlan0]: error adding interface: wpa_supplicant couldn't grab this interface.
<info> [1598862817.0311] device (wlan0): supplicant interface state: starting -> down
<warn> [1598862827.7803] device (wlan0): re-acquiring supplicant interface (#5).
<error> [1598862828.0709] sup-iface[0x14888f0,wlan0]: error adding interface: wpa_supplicant couldn't grab this interface.
<info> [1598862828.0710] device (wlan0): supplicant interface state: starting -> down
<info> [1598862828.0711] device (wlan0): supplicant interface keeps failing, giving up
<info> [1598863236.2463] agent-manager: req[0x14e8e28, :1.44/nmcli-connect/0]: agent registered
<error> [1598863236.2559] audit: failed to open auditd socket: Protocol not supported
<info> [1598863236.2565] audit: op="connection-activate" uuid="a2f9ef1e-e2c1-4b2f-ae09-a92c7fa23519" name="FRITZ!Box 3490" result="fail" reason="No suitable device found for this connection (device eth0 not available because profile is not compatible with device (mismatching interface name))."
 


Hi
Sorry for the delay. I manage to fix this by doing this:

sudo systemctl disable dhcpcd

Not sure what the rules are for this site. Do I close this thread/question.

thanks
 

Members online


Top