NFS shares problems

debrartine

New Member
Credits
26
Pulling my hair out with NFS permissions problems.
If you have worked with NFS you know the one:
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting.......
What get me is that I have many NFs shares set up in a script I run and the others work!
So /mnt/NAS works but /mnt/NAS/testa doesn't! The owner and group are the same. ALL file permissions are exactly the same. Mount command used is the same (except for obviously dif path).
Entry in exports is the same (rw,etc)
If I mount at dif times to the same folder on my clients then one works and the other does not.
e.g.

/mnt/NAS mounted to ~/nfs/NAS ok
/mnt/NAS/testa mounted to ~/nfs/NAS no go (this is after a full reboot)
So:
Script the same
Export entries the same
File permissions the same
Owner and group the same.
Using ip addresses so no prob with host res
The above error is with the -vvv option before anyone asks that one
what am I missing?
 


rsydw

New Member
Credits
48
1.What OS are you using ?
2.What is NFS Version on that system ?
3.Have you tried manually mounting ?If not try manually mounting it like below
mount -t nfs -o [options] /NAS/volume /mount
mount -F nfs -o [options] /NAS/volume /mount
4.Check source what NFS Version your source is compatible with ?
5.Also check NFS daemon is running especially (rpc,mount,client)
6.If it is NFS4 try using NFS3 if it works,google correct option to mount ?
7.It is also woth to check with NAS team what kind of volume it is .Is it UNIX Share or NTFS Share ?
8.Also check exports file of NAS Share if your system have access granted to it ?
Good luck.
 

Lance_L

New Member
Credits
8
I struggled with permissions and NFS shares as well. Make sure you sert both user and group in your NFS mount options. If you have multiple users, create a group for your NFS users and make sure all of your users belong to that group. It looks like you're mounting in your home directory. Check the permissions of that directory and the directory path thereof. Hope this helps.
 


Members online


Top