No wifi adapter found


New Member
Sep 10, 2020
Reaction score
I installed fedora 32 yesterday and I cannot connect to the wifi it says no wifi adapter found and when I run this command

lspci |grep Network
It shows nothing
And when I run this

lspci |grep
It only shows the Ethernet
I updated the software too but the problem remains
The lib folder has the wifi driver which is realtek
I had the same problem before installing fedora too with windows 10 (it was clean install too )there is no option for wifi only the Ethernet was working and I tried to install the drivers manually but it didn't work
This problem happened after I replaced HDD by SSD I don't know if it has anything to do with that
I tried lots of things but nothing worked

Does Fedora include "Non-free" drivers? Are they available in the Fedora repositories?
I don't know as I do not use Fedora (for the past several years anyway).

The easiest solution may be to connect the machine via ethernet, update the drivers, add 'non-free' repositories if needed, run a 'Driver Manager' if Fedora has one, or look for drivers while connected.

P.S. It may make a difference if the above command
lspci |grep Network
has a 'space' between the 'pipe' ( | ) and the following word.

Members online

Latest posts